<!DOCTYPE html> <!-- enableHeaderFooterControlByParameter : false --> <html class="ltr no-js " dir="ltr" lang="en-US"> <head> <meta charset="utf-8"> <meta http-equiv="x-ua-compatible" content="ie=edge"> <meta name="author" content="News Release & Posted By Staff | newsweb@everythinglubbock.com "> <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=no"> <!--Custom meta tags--> <!--page refresh meta start--> <!--page refresh meta end --> <title>Buddy Holly: Life, Legend, Legacy</title> <script type="application/ld+json"> { "@context": "http://schema.org", "publisher": { "@type": "Organization", "name": "EVERYTHINGLUBBOCK" , "logo": { "@type": "ImageObject", "url": "https://media.everythinglubbock.com/nxsglobal/everythinglubbock/theme/images/everythinglubbock_digital_brand.png" } }, "@type": "NewsArticle", "mainEntityOfPage": { "@type": "WebPage", "@id": "https://www.everythinglubbock.com/news/local-news/buddy-holly-life-legend-legacy-september-2018/1413273764" } , "headline": "Buddy Holly: Life, Legend, Legacy", "alternativeHeadline": "Texas Tech University's Southwest Collection/Special Collections Library", "description": "Texas Tech University&rsquo;s Southwest Collection/Special Collections Library will display a new exhibit to honor Lubbock&rsquo;s favorite music son.", "author": { "@type": "Person", "name": "News Release & Posted By Staff | newsweb@everythinglubbock.com " }, "datePublished": "2018-09-02T11:11:09-0500", "dateModified": "2018-09-02T12:18:04-0500", "dateline": "LUBBOCK, Texas (NEWS RELEASE)", "articleBody": "&lt;p&gt;&lt;em&gt;The following is a news release from Texas Tech University:&lt;/em&gt;&lt;/p&gt;&lt;p&gt;Lubbock&amp;rsquo;s favorite music son, Buddy Holly, will be featured in a new exhibit at the&amp;nbsp;Texas Tech University Southwest Collection/Special Collections Library, with a reception and gallery talk for the exhibit at 5 p.m. on Sept. 6.&lt;/p&gt;&lt;p&gt;Parking is available in the lot west of the SWC/SCL, located at 15&lt;sup&gt;th&amp;nbsp;&lt;/sup&gt;Street and Detroit Avenue on the Texas Tech campus. Additional park-and-pay spaces are available in the lot south of the Student Union Building. The public is invited to attend and admission is free.&lt;/p&gt;&lt;p&gt;Since his meteoric rise to fame in the late 1950s and untimely death in a plane crash in 1959, Holly&amp;rsquo;s career has been celebrated globally. The exhibit contains photos, posters, ephemera and artifacts from one of his biggest fans, Bill Griggs. The Bill Griggs Collection is part of the&amp;nbsp;Crossroads of Music Archive&amp;nbsp;in the SWC/SCL.&lt;/p&gt;&lt;p&gt;Griggs is a Connecticut native who grew up devoted to astronomy, steamship travel, hot rods and radio in all its forms.&lt;/p&gt;&lt;p&gt;&amp;ldquo;A particular fan of disc jockey &amp;lsquo;Moondog&amp;rsquo; Alan Freed, he attended one of the DJs &amp;lsquo;Big Beat&amp;rsquo; shows and saw Buddy Holly perform with the Crickets in Hartford on March 30, 1958,&amp;rdquo; said Curtis Peoples, archivist for the SWC/SCL&amp;rsquo;s Crossroads of Music Archive.&lt;/p&gt;&lt;p&gt;When Holly died on Feb. 3, 1959, Griggs began collecting everything he could find, Peoples said. While managing a K-Mart and a 1950s memorabilia mail-order business, he launched the Buddy Holly Memorial Society in 1975 and its quarterly journal Reminiscing. The Buddy Holly Memorial Society hosted its first convention in 1977 with a Crickets reunion concert.&lt;/p&gt;&lt;p&gt;Griggs subsequently published and consulted on a number of books, articles, TV shows and liner notes for recordings. In 1981 he and The Buddy Holly Memorial Society relocated to Lubbock. He began producing music events in Lubbock and Clovis, New Mexico. For two years he ran a rock revival music show on KDAV-AM radio. Eventually, the society, licensed by the Holly estate, enrolled more than 5,500 members from all 50 states and 34 nations, Peoples said.&lt;/p&gt;&lt;p&gt;Griggs published for 30 years and produced 11 consecutive Buddy Holly Memorial Society conventions, as well as serving as master of ceremonies for countless annual reunions at the Surf Ballroom in Clear Lake, Iowa, site of the final concert before &amp;ldquo;the music died.&amp;rdquo; Griggs died in Lubbock on March 29, 2011.&lt;/p&gt;&lt;p&gt;The Bill Griggs Collection was donated to the Crossroads of Music Archive by Texas Tech alumnus Randy Steele, who was placed in charge of caring for the collection after Griggs&amp;rsquo; death. Peoples and Steele met and discovered common threads in their passion for Holly nostalgia and the result was the donation of the collection to the SWC/SCL for public research and exhibition. The exhibit will be showcased at the Buddy Holly Center in 2019.&lt;/p&gt;&lt;p&gt;&lt;u&gt;CONTACT&lt;/u&gt;&lt;b&gt;: &lt;/b&gt;&lt;br /&gt; Curtis Peoples, archivist, Crossroads of Music Archive, Southwest Collection/Special Collections Library, Texas Tech University,&amp;nbsp;(806) 834-5777 or&amp;nbsp;&lt;a data-auth=&#034;NotApplicable&#034; href=&#034;mailto:curtis.peoples@ttu.edu&#034; rel=&#034;noopener noreferrer&#034; target=&#034;_blank&#034;&gt;curtis.peoples@ttu.edu&lt;/a&gt;&lt;/p&gt;&lt;p&gt;(News release from Texas Tech University)&lt;/p&gt;", "image": { "@type": "ImageObject", "url": "https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2017/01/29/Story_799443_ver1.0_1485717577911_16867844_ver1.0_640_360.jpg", "height": "360", "width": "640" } } </script> <!-- META + CSS --> <meta content="text/html; charset=UTF-8" http-equiv="content-type" /> <meta name="description" content="Texas Tech University&amp;rsquo;s Southwest Collection/Special Collections Library will display a new exhibit to honor Lubbock&amp;rsquo;s favorite music son." lang="en-US" /> <meta name="keywords" content="Local News" lang="en-US" /> <script>/*<![CDATA[*/var _head_start=new Date();/*]]>*/</script> <meta property="og:title" content="Buddy Holly: Life, Legend, Legacy"/><meta property="og:description" content="Texas Tech University&rsquo;s Southwest Collection/Special Collections Library will display a new exhibit to honor Lubbock&rsquo;s favorite music son. "/><meta property="og:type" content="article"/><meta property="og:url" content="https://www.everythinglubbock.com/news/local-news/buddy-holly-life-legend-legacy-september-2018/1413273764"/><meta property="og:image" content="https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2017/01/29/Story_799443_ver1.0_1485717577911_16867844_ver1.0_1280_720.jpg"/><meta property="og:image:width" content="1280"/><meta property="og:image:height" content="720"/><meta property="og:locale" content="en_US"/><meta property="og:site_name" content="EVERYTHINGLUBBOCK"/><meta property="fb:app_id" content="453216701501112"/><meta property="article:section" content="Local News"/><meta property="article:tag" content=""/><meta property="article:published_time" content="2018-09-02T17:18:04+0000"/><meta property="article:modified_time" content="2018-09-02T17:18:04+0000"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:title" content="Buddy Holly: Life, Legend, Legacy"/><meta name="twitter:description" content="Texas Tech University&rsquo;s Southwest Collection/Special Collections Library will display a new exhibit to honor Lubbock&rsquo;s favorite music son. "/><meta name="twitter:site" content="EVERYTHINGLUBBOCK"/><meta name="twitter:image" content="https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2017/01/29/Story_799443_ver1.0_1485717577911_16867844_ver1.0_1280_720.jpg"/><meta name="twitter:domain" content="https://www.everythinglubbock.com"/><!-- used for Google CSE --> <!-- <PageMap><DataObject type="Date"><Attribute name="sdateformat" value="20180902 17:18:04"/><Attribute name="edate" value="1535908684128"/><Attribute name="edateformat" value="20180902 17:18:04"/><Attribute name="sdate" value="1535908684228"/></DataObject><DataObject type="Site"><Attribute name="siteId" value="197"/></DataObject><DataObject type="PageAttr"><Attribute name="Category" value="Local News"/></DataObject><DataObject type="Story"><Attribute name="Description" value="Texas Tech University&rsquo;s Southwest Collection/Special Collections Library will display a new exhibit to honor Lubbock&rsquo;s favorite music son. "/><Attribute name="Headline" value="Buddy Holly: Life, Legend, Legacy"/><Attribute name="Keywords" value="Local News"/><Attribute name="Migrated" value="false"/><Attribute name="ModDate" value="20180902 17:18:04"/><Attribute name="PubDate" value="20180902 17:18:04"/><Attribute name="type" value="story"/></DataObject><DataObject type="Thumbnail"><Attribute name="Name" value="16867844"/><Attribute name="Caption" value="<p>(Photo provided by the Buddy Holly Center)</p>"/><Attribute name="Credit" value="None"/><Attribute name="CompID" value="646884642"/><Attribute name="URL" value="https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2017/01/29/Story_799443_ver1.0_1485717577911_16867844_ver1.0_160_90.jpg"/><Attribute name="Title" value="Buddy+Holly+Statue+%28Close+Up%29+-+720"/><Attribute name="Migrated" value="false"/></DataObject><DataObject type="Restrictions"><Attribute name="Status" value="Free"/></DataObject></PageMap> --><!-- social sharing tools --> <link href="https&#x3a;&#x2f;&#x2f;www&#x2e;everythinglubbock&#x2e;com&#x2f;news&#x2f;local-news&#x2f;buddy-holly-life-legend-legacy-september-2018&#x2f;1413273764" rel="canonical" /> <!-- begin: TOP HEAD CSS --> <link href="&#x2f;html&#x2f;css&#x2f;portal&#x2f;aui&#x2e;css&#x3f;themeId&#x3d;nxsmainv2_WAR_nxsmainv2theme&#x26;minifierType&#x3d;css&#x26;languageId&#x3d;en_US&#x26;b&#x3d;6110&#x26;t&#x3d;1526334964000" rel="stylesheet" type="text/css" /> <link href="/html/portlet/journal_content/css/main.css?themeId=nxsmainv2_WAR_nxsmainv2theme&amp;minifierType=css&amp;languageId=en_US&amp;b=6110&amp;t=1535872044000" rel="stylesheet" type="text/css" /> <link href="/html/portlet/asset_publisher/css/main.css?themeId=nxsmainv2_WAR_nxsmainv2theme&amp;minifierType=css&amp;languageId=en_US&amp;b=6110&amp;t=1535872044000" rel="stylesheet" type="text/css" /> <link class="lfr-css-file" href="https&#x3a;&#x2f;&#x2f;www&#x2e;everythinglubbock&#x2e;com&#x2f;nxs-main-v2-theme&#x2f;css&#x2f;main&#x2e;css&#x3f;themeId&#x3d;nxsmainv2_WAR_nxsmainv2theme&#x26;minifierType&#x3d;css&#x26;languageId&#x3d;en_US&#x26;b&#x3d;6110&#x26;t&#x3d;1535693407000" rel="stylesheet" type="text/css" /> <!-- * FONT-AWESOME ICON LIBRARY * for signed-in use only * used for icon-override in ep-cms-surf, and by global page share styles (private, control panel, cms-surf) --> <style type="text/css"></style> <style type="text/css"></style> <!-- end: TOP HEAD CSS --> <!-- Theme Third-Party CSS --> <style type="text/css">.placeholder-16x9,.delay-bg-load.ratio-16x9,.delay-bg-load .ratio-16x9{background-image:url(https://www.everythinglubbock.com/nxs-main-v2-theme/images/color_schemes/everythinglubbock/placeholder/placeholder-16x9.jpg)!important}.placeholder-4x3,.delay-bg-load.ratio-4x3,.delay-bg-load .ratio-4x3{background-image:url(https://www.everythinglubbock.com/nxs-main-v2-theme/images/color_schemes/everythinglubbock/placeholder/placeholder-4x3.jpg)!important}.placeholder-1x1,.delay-bg-load.ratio-1x1,.delay-bg-load .ratio-1x1{background-image:url(https://www.everythinglubbock.com/nxs-main-v2-theme/images/color_schemes/everythinglubbock/placeholder/placeholder-1x1.jpg)!important}</style> <link rel="shortcut icon" href="https://www.everythinglubbock.com/nxs-main-v2-theme/images/color_schemes/everythinglubbock/favicon.ico"> <link rel="apple-touch-icon" href="https://www.everythinglubbock.com/nxs-main-v2-theme/images/color_schemes/everythinglubbock/apple-touch-icon.png"> <style type="text/css"></style> <link href="https://fonts.googleapis.com/css?family=Libre+Franklin:400,700" rel="stylesheet"> <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css"> <!-- JS --> <!-- begin: TOP HEAD JS --> <script type="text/javascript">/*<![CDATA[*/var Liferay={Browser:{acceptsGzip:function(){return true},getMajorVersion:function(){return 604.4},getRevision:function(){return"604.4.7"},getVersion:function(){return"604.4.7"},isAir:function(){return false},isChrome:function(){return false},isFirefox:function(){return false},isGecko:function(){return true},isIe:function(){return false},isIphone:function(){return true},isLinux:function(){return false},isMac:function(){return true},isMobile:function(){return true},isMozilla:function(){return false},isOpera:function(){return false},isRtf:function(){return false},isSafari:function(){return false},isSun:function(){return false},isWap:function(){return false},isWapXhtml:function(){return false},isWebKit:function(){return true},isWindows:function(){return false},isWml:function(){return false}},Data:{isCustomizationView:function(){return false},notices:[null]},ThemeDisplay:{getCDNDynamicResourcesHost:function(){return""},getCDNHost:function(){return""},getCompanyId:function(){return"10155"},getCompanyGroupId:function(){return"10187"},getUserId:function(){return"10159"},getDoAsUserIdEncoded:function(){return""},getPlid:function(){return"1067173702"},getLayoutId:function(){return"1231"},getLayoutURL:function(){return"https://www.everythinglubbock.com/story"},isPrivateLayout:function(){return"false"},getParentLayoutId:function(){return"0"},getScopeGroupId:function(){return"54787063"},getScopeGroupIdOrLiveGroupId:function(){return"54787063"},getParentGroupId:function(){return"54787063"},isImpersonated:function(){return false},isSignedIn:function(){return false},getDefaultLanguageId:function(){return"en_US"},getLanguageId:function(){return"en_US"},isAddSessionIdToURL:function(){return false},isFreeformLayout:function(){return false},isStateExclusive:function(){return false},isStateMaximized:function(){return false},isStatePopUp:function(){return false},getPathContext:function(){return""},getPathImage:function(){return"/image"},getPathJavaScript:function(){return"/html/js"},getPathMain:function(){return"/c"},getPathThemeImages:function(){return"https://www.everythinglubbock.com/nxs-main-v2-theme/images"},getPathThemeRoot:function(){return"/nxs-main-v2-theme/"},getURLControlPanel:function(){return"/group/control_panel?doAsGroupId=54787063&refererPlid=1067173702"},getURLHome:function(){return"https://www.everythinglubbock.com/web/guest"},getSessionId:function(){return"5773FA6C0B0B69A7B6DFDD435BA2AE18"},getPortletSetupShowBordersDefault:function(){return false}},PropsValues:{NTLM_AUTH_ENABLED:false}};var themeDisplay=Liferay.ThemeDisplay;Liferay.AUI={getBaseURL:function(){return"https://www.everythinglubbock.com/html/js/aui/"},getCombine:function(){return true},getComboPath:function(){return"/combo/?minifierType=&languageId=en_US&b=6110&t=1535895760000&p=/html/js&"},getFilter:function(){return{replaceStr:function(c,b,a){return b+"m="+(c.split("/html/js")[1]||"")},searchExp:"(\\?|&)/([^&]+)"}},getJavaScriptRootPath:function(){return"/html/js"},getLangPath:function(){return"aui_lang.jsp?themeId=nxsmainv2_WAR_nxsmainv2theme&colorSchemeId=23&minifierType=js&languageId=en_US&b=6110&t=1535895760000"},getRootPath:function(){return"/html/js/aui/"}};window.YUI_config={base:Liferay.AUI.getBaseURL(),comboBase:Liferay.AUI.getComboPath(),fetchCSS:true,filter:Liferay.AUI.getFilter(),root:Liferay.AUI.getRootPath(),useBrowserConsole:false};Liferay.currentURL="\x2fnews\x2flocal-news\x2fbuddy-holly-life-legend-legacy-september-2018\x2f1413273764";Liferay.currentURLEncoded="%2Fnews%2Flocal-news%2Fbuddy-holly-life-legend-legacy-september-2018%2F1413273764";/*]]>*/</script> <script src="/html/js/barebone.jsp?themeId=nxsmainv2_WAR_nxsmainv2theme&amp;colorSchemeId=23&amp;minifierType=js&amp;minifierBundleId=javascript.barebone.files&amp;languageId=en_US&amp;b=6110&amp;t=1&amp;epversion=4.2.1.1" type="text/javascript"></script> <script type="text/javascript">/*<![CDATA[*/(function(){window.EP=window.EP||{};EP.CONST={versionStr:"?epversion=4.2.1.1",useTempData:false,staticResourceRemoteHost:"",isStaticResourceRemoteEnabled:false,isShowImageStatusEnabled:false};EP.Anvato=EP.Anvato||{};EP.Anvato.sdkUrl="//w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js";EP.Anvato.accessKey="grD7zQN7qx1J2UXG8eUkmSo3lP1ARBao";EP.Anvato.disableAnvatoTokenAccessKey=false;EP.Anvato.disableAnvatoGoogleAnalysis=false})();/*]]>*/</script> <script type="text/javascript">/*<![CDATA[*/Liferay.Portlet.list=["56_INSTANCE_9942","101_INSTANCE_9vk2T4Pg4hCn","56_INSTANCE_7YZl9JcCZKtW","56_INSTANCE_6700","56_INSTANCE_7893","56_INSTANCE_fEq1SSBStHnQ","56_INSTANCE_8763","56_INSTANCE_Xzo6BJEInqK3","56_INSTANCE_0078","56_INSTANCE_3080","56_INSTANCE_3307","56_INSTANCE_8867","56_INSTANCE_2827"];/*]]>*/</script> <!-- No service worker configured for this site --> <!-- Add for optimization --> <script src="/html/js/barebone.jsp?themeId=nxsmainv2_WAR_nxsmainv2theme&amp;colorSchemeId=23&amp;minifierType=js&amp;minifierBundleId=endplay.javascript.barebone.files&amp;languageId=en_US&amp;b=6110&amp;t=1&amp;epversion=4.2.1.1" type="text/javascript"></script> <!-- Amino UI-Hook Override --> <script type="text/javascript">/*<![CDATA[*/(function(a){a.mix(Liferay.ThemeDisplay,{getScopeGroupName:function(){return"EVERYTHINGLUBBOCK"},getParentGroupName:function(){return"EVERYTHINGLUBBOCK"},isControlPanel:function(){return false}})})(AUI());/*]]>*/</script> <!-- JQUERY / JQUERY MIGRATE / MODERNIZR / MODERNIZR EXT/ PUBLIC.js --> <script src="/html/js/endplay/site-public.js?epversion=4.2.1.1" type="text/javascript"></script> <!-- NXS UI Framework Hook --> <script src="/combo/?browserId=other&minifierType=js&languageId=en_US&p=/html/js/&m=nxs/NxsComponents.js&epversion=4.2.1.1" type="text/javascript"></script> <script type="text/javascript">/*<![CDATA[*/var viewStoryUrl="/group/everythinglubbock/create-story?type=story&storyId=";var viewNonstoryUrl="/web/everythinglubbock-staging/-/";var viewGalleryUrl="/group/everythinglubbock/create-gallery?type=gallery&storyId=";var companyId=themeDisplay.getCompanyId();var groupId=54787082;/*]]>*/</script> <script type="text/javascript">/*<![CDATA[*/Liferay.ThemeDisplay.getVocabularyIds=function(){return"54787090"};Liferay.ThemeDisplay.getVocabularyGroupIds=function(){return"54787082"};/*]]>*/</script> <script async src="//js-sec.indexww.com/ht/p/184979-164251977320883.js"></script> <script type="text/javascript" src="//mtrx.go.sonobi.com/morpheus.mass2.1984.js"></script><!-- include the google tag for core ad implementation --> <script type="text/javascript">/*<![CDATA[*/var googletag=googletag||[];googletag.cmd=googletag.cmd||[];(function(){var a=document.createElement("script");a.async=true;a.type="text/javascript";var c="https:"==document.location.protocol;a.src=(c?"https:":"http:")+"//www.googletagservices.com/tag/js/gpt.js";var b=document.getElementsByTagName("script")[0];b.parentNode.insertBefore(a,b)})();/*]]>*/</script> <script type="text/javascript">/*<![CDATA[*/(function(){EP=EP||{};var a={pageUrl:"https://www.everythinglubbock.com/news/local-news/buddy-holly-life-legend-legacy-september-2018/1413273764",pageType:"story",pageKeywords:"news story template - do not publish",articleId:"1413273764",adUnitSubName:"/news/local_news"};EP.AdConfig=a})();/*]]>*/</script> <!-- end: TOP HEAD JS --> <!-- Theme JS --> <script type="text/javascript">/*<![CDATA[*/window._taboola=window._taboola||[];_taboola.push({article:"auto"});!function(d,c,a,b){if(!document.getElementById(b)){d.async=1;d.src=a;d.id=b;c.parentNode.insertBefore(d,c)}}(document.createElement("script"),document.getElementsByTagName("script")[0],"//cdn.taboola.com/libtrc/$taboolaPublisherId/loader.js","tb_loader_script");if(window.performance&&typeof window.performance.mark=="function"){window.performance.mark("tbl_ic")};/*]]>*/</script> <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-57c0ac6f3a419a46" async="async"></script> <script type="text/javascript">/*<![CDATA[*/var addthis_config=addthis_config||{};addthis_config.data_track_addressbar=false;addthis_config.data_track_clickback=false;/*]]>*/</script> <!-- START EMBED --> <script src="https://api.b2c.com/api/init-3822h1xdo2bjghb73i1.js" data-cfasync="false" async></script> <noscript><img src="https://api.b2c.com/api/noscript-3822h1xdo2bjghb73i1.gif"></noscript> <!-- END EMBED --> <!-- begin: Header Customized Content --> <!-- start: Google Verification --><meta content="HWbORwOH0OZMh6naBffHQ9zxwnwnPkY9WRPtMP5ev7k" name="google-site-verification" /><meta name="google-site-verification" content="kPK4SuyalvYD5qw1rCWtDalaQYqpO7Tn9eTBrPVjxFs" /><!-- end: Google Verification --><!-- start: Facebook Verification --><meta content="140588565954380" property="fb:pages" /><meta content="100662759989507" property="fb:pages" /><!-- end: Facebook Verification --><script>/*<![CDATA[*/var trackOutboundLink=function(a){ga("send","event","outbound","click",a,{transport:"beacon",hitCallback:function(){document.location=a}})};/*]]>*/</script> <!-- end: Header Customized Content --> <!--Google Analytics start--> <script type="text/javascript">/*<![CDATA[*/(function(b,a){var c=function(){if(!window.EPCOREGAInstance&&(false==false||true==true)){var k="LakanaSite:UA-71390505-1,nxstSite:UA-37144901-20";var j="LakanaClientRollup:UA-57382719-1";var h=[];if(j){var e=j.split(":");if(e){h.push({name:e[0],propertyId:e[1],demographics:true})}}if(k){var g=k.split(",");if(g){for(var f in g){var e=g[f].split(":");h.push({name:e[0],propertyId:e[1],demographics:true})}}}for(var f in h){h[f].domainName="everythinglubbock.com"}var d=[];var l=new EP.Components.Analytics.GA(null,h,d);window.EPCOREGAInstance=l}};window.EPCOREGAEvent=function(f,g,e,h,d){if(window.EPCOREGAInstance){window.EPCOREGAInstance.event(f,g,e,h,d)}else{AUI().use("google-analytics",function(i){c();if(window.EPCOREGAInstance){window.EPCOREGAInstance.event(f,g,e,h,d)}})}};window.EPCOREVirtualPageview=function(e,d){if(window.EPCOREGAInstance){window.EPCOREGAInstance.virtualPageview(e,d)}else{AUI().use("google-analytics",function(f){c();if(window.EPCOREGAInstance){window.EPCOREGAInstance.virtualPageview(e,d)}})}};AUI().use("google-analytics",function(g){var l="EVERYTHINGLUBBOCK";var m="";var i="none";var k="none";var d="none";var f="none";var e="none";var h="none";m="story";i="News Release & Posted By Staff | newsweb@everythinglubbock.com ";k="1413273764";d="EVERYTHINGLUBBOCK";f="Local News";e="nxs";h="none";if(m==null||m==""){m="article"}if(i==null||i==""){i="none"}if(k==null||k==""){k="none"}if(d==null||d==""){d="none"}if(f==null||f==""){d="none"}if(e==null||e==""){e="LAKANA"}if(h==null||h==""){h="none"}var j=[{name:"dimension1",value:e},{name:"dimension2",value:l},{name:"dimension3",value:f},{name:"dimension4",value:m},{name:"dimension5",value:k},{name:"dimension6",value:d},{name:"dimension7",value:i},{name:"dimension8",value:h}];c();if(window.EPCOREGAInstance){window.EPCOREGAInstance.pageview(j)}})})(jQuery,AUI());/*]]>*/</script> <!--Google Analytics end--> <!-- begin: Quantcast --> <!-- end: Quantcast --> <!-- Nativo Integration Start --> <script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script> <!-- Nativo Integration End --> <script>/*<![CDATA[*/(function(){var a="004062674113170901233:4qd-hlfg0-m";var c=document.createElement("script");c.type="text/javascript";c.async=true;c.src=(document.location.protocol=="https:"?"https:":"http:")+"//www.google.com/cse/cse.js?cx="+a;var b=document.getElementsByTagName("script")[0];b.parentNode.insertBefore(c,b)})();/*]]>*/</script> <script>/*<![CDATA[*/(function(){window.dataLayer=window.dataLayer||[];dataLayer.push({pageType:"Article"})})();/*]]>*/</script> <script src="https://play.syndicaster.tv/static/scripts/embed.js"></script> <script>/*<![CDATA[*/(function(a,b){var c=(window.location.protocol==="https:")?"https":"http";window.NXS=window.NXS||{};NXS.Util=NXS.Util||{};NXS.Util=a.mix(NXS.Util,{embedSyndicasterVideo:function(g,d,f){if(d==null){return}var h="/nxs-main-v2-theme/jsp/video.jsp?themeId=nxsmainv2_WAR_nxsmainv2theme&colorSchemeId=23&minifierType=js&languageId=en_US&b=6110&t=1535693407000";d=a.mix({aspect_ratio:"16x9",auto_next:0,page_count:5,show_title:1,windows:1,width:690,height:388},d,true);var e=function(i){h+=("&config="+encodeURIComponent(i(d)));var j=b("<iframe>",{frameborder:"0",scrolling:"no",allowfullscreen:"true",webkitallowfullscreen:"true",mozallowfullscreen:"true"});j.attr(f?"data-src":"src",h);if(f){j.addClass(f.scroll?"delay-iframe-load":"delay-load")}j.appendTo(g.empty().addClass("wrapper-video syndicaster-video iframed"))};if(window.JSON&&JSON.stringify&&JSON.parse){e(JSON.stringify)}else{a.use("json-parse","json-stringify",function(){e(a.JSON.stringify)})}},embedJWPlayVideo:function(g,e){if(e==null){return}e=a.mix({div_id:a.guid("videoplayer-"),width:690,height:388},e,true);var d=g.width();var f=(e.height*d)/e.width;e.width=Math.round(d);e.height=Math.round(f);g.html('<div class="syndicaster-video" id='+e.div_id+">\x3C/div>");cm=new CMPlayer(e.div_id).setup(e)}},true)})(AUI(),jQuery);/*]]>*/</script> <!-- BEGIN : Analytics JS Tag --> <script async type="text/javascript" id="bob_tag_loader">/*<![CDATA[*/var cats="Local News";var bob_kw="Local News";var bob_desc="Texas\x20Tech\x20University\x26rsquo\x3bs\x20Southwest\x20Collection\x2fSpecial\x20Collections\x20Library\x20will\x20display\x20a\x20new\x20exhibit\x20to\x20honor\x20Lubbock\x26rsquo\x3bs\x20favorite\x20music\x20son\x2e\x20";var cat_data="&cats="+cats+"&bob_kw="+bob_kw+"&bob_desc="+bob_desc;console.log("analytics JS tag -- cat_data:"+cat_data);var bob_cb="1";bob_cb=((new Date()).getTime()+""+Math.floor(Math.random()*1000000)).substr(0,16);(function(){var b=document.createElement("script");b.type="text/javascript";b.async=true;b.id="bob_tag";b.src=("https:"==document.location.protocol?"https://":"http://")+"bob.dmpxs.com/static/bob_001.js?bob_cb="+bob_cb+cat_data;var a=document.getElementsByTagName("script")[0];a.parentNode.insertBefore(b,a)})();/*]]>*/</script> <!-- END : Analytics JS Tag --> <!-- BEGIN : Confiant Code --> <script>/*<![CDATA[*/(function(){var a=window;var c="clarium.global.ssl.fastly.net";a._clrm=a._clrm||{};a._clrm.gpt={propertyId:"Y2Nn8JmiAY8HpnF4sl5n7J71jaI",confiantCdn:c,mapping:"W3siaSI6MiwidCI6Int7b319Ont7d319eHt7aH19IiwicCI6MCwiRCI6MSwiciI6W119XQ==",activation:"|||MTg0MDQ0NTgy,|||MjIxMDg3ODYy,|||MjIxMDg4MTAy,|||MjIxMDg5MDYy,|||MjIxMDkwNTAy,|||MjEwNDM3ODYy,|||MjE5NTY0MzQy,|||MjE5NTY2MDIy,|||MjE5NTY5Mzgy,|||MjE5NTY5ODYy,|||MjE5NTcxMzAy,|||MjEwNTE4OTkwOA==,|||MjEwODUyNjg1OQ==,|||MjEyNjc0ODQwOQ==,|||MjEzMzUwMDMwMg==,|||MjE3MTY1NzI3NA==,|||MjE3MTY1NzQwMA==,|||MjE3MTY1NzcyNA==,|||MTg0MDQ0NTgy",callback:function(e,h,i,j,g,f){console.log("w00t one more bad ad nixed.",arguments)}};var d=document.createElement("script");d.async=true;d.src="//"+c+"/gpt/a/wrap.js";var b=document.getElementsByTagName("script")[0];b.parentNode.insertBefore(d,b)})();/*]]>*/</script> <!-- END : Confiant Code --> <link rel="stylesheet" href="/html/js/endplay/framework/jquery/jquery.smartbanner.css" /><script>/*<![CDATA[*/(function(c,g,d,b,a){var e=navigator.userAgent;var f=$("<meta />").attr({name:function(){if(/iphone|ipad|ipod/i.test(e)){return"apple-itunes-app"}else{if(/android/i.test(e)){return"google-play-app"}else{return null}}},content:function(){if(/ipad/i.test(e)){return"app-id="+g}else{if(/ipod/i.test(e)){return"app-id="+d}else{if(/iphone/i.test(e)){return"app-id="+c}else{if(/android/i.test(e)&&/mobile/i.test(e)){return"app-id="+b}else{if(/android/i.test(e)&&!/mobile/i.test(e)){return"app-id="+a}else{return null}}}}}}});if(f.attr("name")!=null&&f.attr("content")!=null){$("head").prepend(f)}})("641339887","641339887","641339887","com.newssynergy.everythinglubbock","com.newssynergy.everythinglubbock");AUI().use("jquery-smartbanner",function(a){$(document).ready(function(){var b=$("body"),c=function(){$("#smartbanner").hide();b.removeClass("smartbanner-visible")};$.smartbanner({title:"EverythingLubbock - KAMC KLBK",icon:"",author:"Nexstar Broadcasting",daysHidden:"90",daysReminder:"180",onInstall:function(){c()},onClose:function(){c()}});if($("#smartbanner").length){b.addClass("smartbanner-visible")}})});/*]]>*/</script> <!-- Head client custom content --> </head> <body class="skin-everythinglubbock controls-visible signed-out public-page organization-site"> <!--[if lt IE 9]> <p class="browserupgrade">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a> to improve your experience.</p> <![endif]--> <!-- begin: WRAPPER --> <div id="wrapper"> <!-- begin: HEADER --> <header id="header"> <script type='text/javascript'>var _sf_startpt=(new Date()).getTime();</script> <div id="site-header"> <div class="row"> <div class="column"> <a id="toggle-menu" class="nav-bar-button left" href="#"><i class="fa fa-navicon navicon"></i><i class="fa fa-close close"></i></a> <a class="nav-bar-button right weather" href="https://www.everythinglubbock.com/weather"> <span class="region">Lubbock</span> <h4 class="forecast">83&deg;<i class=" lwi lwi-day-partly-sunny small "></i></h4> </a> <a href="#" class="nav-bar-button right user" data-reveal-id="modal-user"><i class="fa fa-user"></i></a> <div class="site-logo"><a href="/" title="Go to EVERYTHINGLUBBOCK"><img src="https://media.everythinglubbock.com/nxsglobal/everythinglubbock/theme/images/everythinglubbock_digital_brand.png" alt="EVERYTHINGLUBBOCK" /><div class="site-logo-wrapper" style="background:url(https://media.everythinglubbock.com/nxsglobal/everythinglubbock/theme/images/everythinglubbock_digital_brand.png)"></div></a></div> <div class="site-search"> <form> <input type="text" placeholder="Site Search..." id="site-search-mobile__field">
                    <a href="#" class="button" id="site-search-mobile__button"><i class="fa fa-search"></i></a>
                </form>
                                    <script>
                        (function($, A){
                            window.setTimeout(function() {
                                                                                                                                                                                                                                            $("#site-search-mobile__button").click(function(e) {
                                        e.preventDefault();
                                        var t = $("#site-search-mobile__field").val().trim();
                                        if (t !== "") {
                                            window.location = "/search?q=" + t;
                                        }
                                    });
                                    $('#site-search__field').keydown(function(e){
                                        if(e.keyCode === 13){
                                            e.preventDefault();
                                            var t = $("#site-search-mobile__field").val().trim();
                                            if (t !== "") {
                                                window.location = "/search?q=" + t;
                                            }
                                        }
                                     });
                                                            }, 0);
                        })( jQuery, AUI() ); 
                    </script>
            </div>

                                                                                    <div class="sponsor">
                            <label>Sponsored by</label>
                                                                                    
                        
        
        
            
            
        
        
            
        
            
            
            
            
            
            
                
        
         
    <!-- Begin: Ad -->    
        <div id="header-microbar-124598" class="mod-ad header-microbar" data-ad-json='{"baseAdUnitPath":"nx.klbk","contentId":"","isCompanion":false,"isOOP":false,"networkID":"5678","disableRefreshOnResize":false,"siteKey":"","size":[[88, 31]],"lazyLoadDisabled":false,"moduleRefreshable":false,"pos":"header-microbar","modid": "MOD-AMINO-HEADER","wxTargeting":{"skycond":"","temp":"","svwx":false,"sclose":false,"precip":"0"}}'></div>
        <script type="text/javascript">
                        if(EP && EP.Utils && EP.Utils.AdUtils) {
                EP.Utils.AdUtils.registerAd("header-microbar-124598");
            }
        </script>
    <!-- End: Ad -->
    
                        </div>                
                                                
            <ul class="weather">
                                                         <li><a href="https://www.everythinglubbock.com/weather">
       <h5 class="region">Lubbock</h5>
       <h4 class="forecast">83&deg;<i class="    lwi lwi-day-partly-sunny small
    " style="    "></i></h4>
      </a></li>
                                 </ul>
        </div>
    </div>
</div>
    
 

            












    		        

    



















































			


















































































        














































































<nav id="site-nav">
    <div class="row">
        <div class="column">
            <ul class="site-links">
                                
                                                                                                                                                                
                                                                                    <li class="has-sub-links">
                                    <a class="accordion-toggle" data-dropdown-accordion="drop-nav-news" href="#"></a>
                                                            <a href="https://www.everythinglubbock.com/news/local-news" data-dropdown="drop-nav-news" data-options="is_hover:true; hover_timeout:1000">NEWS</a>
                                  
 
            
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                      
        
                                                                 <div id="drop-nav-news" data-dropdown-content aria-autoclose="false" class="f-dropdown content width-full">
                                    <ul class="sub-links">
                                                                    
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/news/local-news">LOCAL & OTHER NEWS</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/kamc-28">KAMC NEWS</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/klbk-13">KLBK NEWS</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/kamc-livestream">KAMC LIVESTREAM</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/klbk-livestream">KLBK LIVESTREAM</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/news/national-news">NATIONAL NEWS</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/news/entertainment-news">ENTERTAINMENT NEWS</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/news/business">BUSINESS NEWS</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/news/agjournal">AG JOURNAL</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/news/trendsandfriends">TRENDS AND FRIENDS</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/yourelectionhq">ELECTION HQ</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/kelbycam">KELBYCAM</a></li>
                                                                            </ul>
                                    
                                    
                                    
                                                                            <ul class="list media large-block-grid-2">
                                                                                                                                                
                                                    

                                                    
                                                    
                                                                                                                                                                                                                                                                                                    <li>
                                                        <div class="image-wrapper">
                                                            <a href="/news/local-news/man-arrested-in-fatal-hit-and-run-crash-in-plainview-late-friday-evening/1412265577" >
                                                            
                                                                                <figure class="crop-photo image " style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2018/09/01/AsimDizdarevic720_1535845727939_53906822_ver1.0_640_360.jpg');">
                                                                    <img src="https://www.everythinglubbock.com/nxs-main-v2-theme/images/placeholder/placeholder-16x9.jpg" alt="Man arrested for fatal hit-and-run crash in Plainview late Friday evening">
                                                                </figure>
                                                            </a>
                                                                   <small class="copyright"></small>
                                                         </div>
                                                        <div class="headline-wrapper">
                                                            <h4 class="headline">
                                                                <a href="/news/local-news/man-arrested-in-fatal-hit-and-run-crash-in-plainview-late-friday-evening/1412265577" >
                                                                    Man arrested for fatal hit-and-run crash in Plainview late Friday evening
                                                                </a>
                                                            </h4>
                                                        </div>
                                                    </li>
                                                                                                                                                                                                
                                                    

                                                    
                                                    
                                                                                                                                                                                                                                                                                                    <li>
                                                        <div class="image-wrapper">
                                                            <a href="/news/local-news/reminder-city-of-lubbock-offices-closed-monday-september-3-2018-for-the-labor-day-holiday/1413386434" >
                                                            
                                                                                <figure class="crop-photo image " style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2015/08/30/White%20Background_1440957046180_4630327_ver1.0_640_360.jpg');">
                                                                    <img src="https://www.everythinglubbock.com/nxs-main-v2-theme/images/placeholder/placeholder-16x9.jpg" alt="Reminder: City of Lubbock offices closed Monday, September 3 for the Labor Day holiday">
                                                                </figure>
                                                            </a>
                                                                   <small class="copyright"></small>
                                                         </div>
                                                        <div class="headline-wrapper">
                                                            <h4 class="headline">
                                                                <a href="/news/local-news/reminder-city-of-lubbock-offices-closed-monday-september-3-2018-for-the-labor-day-holiday/1413386434" >
                                                                    Reminder: City of Lubbock offices closed Monday, September 3 for the Labor Day holiday
                                                                </a>
                                                            </h4>
                                                        </div>
                                                    </li>
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                    </ul>
                                                                        
                                                                            <ul class="list headlines">
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                <li><a href="/news/local-news/medicare-part-d-open-enrollment-presentations-scheduled-in-september-october/1413375681" >Medicare Part D open enrollment presentations scheduled in September, October</a></li>
                                                                                                                                                                                                                                                                                                                                        <li><a href="/news/local-news/buddy-holly-center-to-host-buddy-s-82nd-birthday-bash-on-friday-september-7/1404291151" >Buddy Holly Center to host Buddy's 82nd Birthday Bash on Friday, September 7</a></li>
                                                                                                                                                                                                                                                                                                                                        <li><a href="/news/local-news/buddy-holly-life-legend-legacy-september-2018/1413273764" >Buddy Holly: Life, Legend, Legacy</a></li>
                                                                                                                                                                                                                                                                                                                                        <li><a href="/news/local-news/schedule-of-upcoming-events-at-the-lubbock-public-library-september-2-8/1413257108" >Schedule of upcoming events at the Lubbock Public Library, September 2-8</a></li>
                                                                                                                                    </ul>
                                                                                                    </div>
                                                            </li>
                                                            
                                                                                                                                                                
                                                                                    <li class="has-sub-links">
                                    <a class="accordion-toggle" data-dropdown-accordion="drop-nav-weather" href="#"></a>
                                                            <a href="https://www.everythinglubbock.com/weather" data-dropdown="drop-nav-weather" data-options="is_hover:true; hover_timeout:1000">WEATHER</a>
                                  
 
            
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                      
        
                                                                 <div id="drop-nav-weather" data-dropdown-content aria-autoclose="false" class="f-dropdown content width-full">
                                    <ul class="sub-links">
                                                                    
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/weather/kamc-weather">KAMC WEATHER</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/weather/klbk-weather">KLBK WEATHER</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/interactive-radar">INTERACTIVE RADAR</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/weather-alerts">WEATHER ALERTS</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/closings-and-delays">CLOSINGS AND DELAYS</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/forecast">FORECAST</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/weather/almanac">ALMANAC</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/weather/extremeweather">EXTREME WX PREPAREDNESS</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/weather/ski-report">SKI REPORT</a></li>
                                                                            </ul>
                                    
                                    
                                    
                                                                            <ul class="list media large-block-grid-2">
                                                                                                                                                
                                                                                                        

                                                                                                        
                                                    
                                                                                                                                                                                                                                                                                                                                                        <li>
                                                        <div class="image-wrapper">
                                                            <a href="/weather/kamc-weather/kamc-hd-storm-team-weather-webcast-090118/1412818331" >
                                                            
                                                                                <figure class="crop-photo image add-play-icon" style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2018/09/01/KAMC_Evening_Weather_Update_09_01_18_0_53928475_ver1.0_640_360.jpg');">
                                                                    <img src="https://www.everythinglubbock.com/nxs-main-v2-theme/images/placeholder/placeholder-16x9.jpg" alt="KAMC HD Storm Team Weather Webcast 09.01.18">
                                                                </figure>
                                                            </a>
                                                                   <small class="copyright"></small>
                                                         </div>
                                                        <div class="headline-wrapper">
                                                            <h4 class="headline">
                                                                <a href="/weather/kamc-weather/kamc-hd-storm-team-weather-webcast-090118/1412818331" >
                                                                    KAMC HD Storm Team Weather Webcast 09.01.18
                                                                </a>
                                                            </h4>
                                                        </div>
                                                    </li>
                                                                                                                                                                                                
                                                                                                        

                                                                                                        
                                                    
                                                                                                                                                                                                                                                                                                                                                        <li>
                                                        <div class="image-wrapper">
                                                            <a href="/weather/klbk-weather/klbk-september-1st-evening-forecast/1412691095" >
                                                            
                                                                                <figure class="crop-photo image add-play-icon" style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2018/09/01/KLBK_September_1st_Evening_Forecatst_0_53925140_ver1.0_640_360.jpg');">
                                                                    <img src="https://www.everythinglubbock.com/nxs-main-v2-theme/images/placeholder/placeholder-16x9.jpg" alt="KLBK September 1st Evening Forecast">
                                                                </figure>
                                                            </a>
                                                                   <small class="copyright"></small>
                                                         </div>
                                                        <div class="headline-wrapper">
                                                            <h4 class="headline">
                                                                <a href="/weather/klbk-weather/klbk-september-1st-evening-forecast/1412691095" >
                                                                    KLBK September 1st Evening Forecast
                                                                </a>
                                                            </h4>
                                                        </div>
                                                    </li>
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                    </ul>
                                                                        
                                                                            <ul class="list headlines">
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                <li><a href="/weather/klbk-weather/august-31st-2018-evening-weather/1410307917" >August 31st, 2018 Evening Weather</a></li>
                                                                                                                                                                                                                                                                                                                                        <li><a href="/weather/klbk-weather/klbk-august-31st-morning-forecast/1409180511" >KLBK August 31st Midday Forecast</a></li>
                                                                                                                                                                                                                                                                                                                                        <li><a href="/weather/kamc-weather/kamc-hd-storm-team-weather-webcast-83118/1409179927" >KAMC HD Storm Team Weather Webcast 8.31.18</a></li>
                                                                                                                                                                                                                                                                                                                                        <li><a href="/weather/klbk-weather/august-30th-2018-evening-weather/1407927671" >August 30th, 2018 Evening Weather</a></li>
                                                                                                                                    </ul>
                                                                                                    </div>
                                                            </li>
                                                            
                                                                                                                                                                
                                                                                    <li class="has-sub-links">
                                    <a class="accordion-toggle" data-dropdown-accordion="drop-nav-sports" href="#"></a>
                                                            <a href="https://www.everythinglubbock.com/sports" data-dropdown="drop-nav-sports" data-options="is_hover:true; hover_timeout:1000">SPORTS</a>
                                  
 
            
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                      
        
                                                                 <div id="drop-nav-sports" data-dropdown-content aria-autoclose="false" class="f-dropdown content width-full">
                                    <ul class="sub-links">
                                                                    
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/sports/red-raider-nation">RED RAIDER NATION</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/sports/klbk-sports">KLBK SPORTS CONNECTION</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/texas-rangers">TEXAS RANGERS</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/sports/silver-star-nation">SILVER STAR NATION</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/big-race-daytona">BIG RACE DAYTONA</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/south-korea-2018">SOUTH KOREA 2018</a></li>
                                                                            </ul>
                                    
                                    
                                    
                                                                            <ul class="list media large-block-grid-2">
                                                                                                                                                
                                                                                                        

                                                                                                        
                                                    
                                                                                                                                                                                                                                                                                                                                                        <li>
                                                        <div class="image-wrapper">
                                                            <a href="/sports/klbk-sports/frenship-falls-in-shootout-against-amarillo-high/1410926559" >
                                                            
                                                                                <figure class="crop-photo image add-play-icon" style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2018/08/31/Frenship_Falls_to_Amarillo_High_0_53833107_ver1.0_640_360.jpg');">
                                                                    <img src="https://www.everythinglubbock.com/nxs-main-v2-theme/images/placeholder/placeholder-16x9.jpg" alt="Frenship falls in shootout against Amarillo High">
                                                                </figure>
                                                            </a>
                                                                   <small class="copyright"></small>
                                                         </div>
                                                        <div class="headline-wrapper">
                                                            <h4 class="headline">
                                                                <a href="/sports/klbk-sports/frenship-falls-in-shootout-against-amarillo-high/1410926559" >
                                                                    Frenship falls in shootout against Amarillo High
                                                                </a>
                                                            </h4>
                                                        </div>
                                                    </li>
                                                                                                                                                                                                
                                                                                                        

                                                                                                        
                                                    
                                                                                                                                                                                                                                                                                                                                                        <li>
                                                        <div class="image-wrapper">
                                                            <a href="/sports/klbk-sports/monterey-falls-to-odessa-high/1410925680" >
                                                            
                                                                                <figure class="crop-photo image add-play-icon" style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2018/08/31/Monterey_Falls_Flat_Against_Odessa_High_0_53833127_ver1.0_640_360.jpg');">
                                                                    <img src="https://www.everythinglubbock.com/nxs-main-v2-theme/images/placeholder/placeholder-16x9.jpg" alt="Monterey falls to Odessa High">
                                                                </figure>
                                                            </a>
                                                                   <small class="copyright"></small>
                                                         </div>
                                                        <div class="headline-wrapper">
                                                            <h4 class="headline">
                                                                <a href="/sports/klbk-sports/monterey-falls-to-odessa-high/1410925680" >
                                                                    Monterey falls to Odessa High
                                                                </a>
                                                            </h4>
                                                        </div>
                                                    </li>
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                    </ul>
                                                                        
                                                                            <ul class="list headlines">
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                <li><a href="/sports/klbk-sports/lamesa-outlasts-lake-view/1410924945" >Lamesa outlasts Lake View</a></li>
                                                                                                                                                                                                                                                                                                                                        <li><a href="/sports/klbk-sports/trinity-christian-defeats-wheeler/1410924642" >Trinity Christian defeats Wheeler</a></li>
                                                                                                                                                                                                                                                                                                                                        <li><a href="/sports/klbk-sports/levelland-shuts-out-plainview/1410923400" >Levelland shuts out Plainview</a></li>
                                                                                                                                                                                                                                                                                                                                        <li><a href="/sports/klbk-sports/springlake-earth-outlasts-smyer/1410923857" >Springlake-Earth Outlasts Smyer</a></li>
                                                                                                                                    </ul>
                                                                                                    </div>
                                                            </li>
                                                            
                                                                                                                                                                
                                                                                    <li class="has-sub-links">
                                    <a class="accordion-toggle" data-dropdown-accordion="drop-nav-contests" href="#"></a>
                                                            <a href="https://www.everythinglubbock.com/contests" data-dropdown="drop-nav-contests" data-options="is_hover:true; hover_timeout:1000">CONTESTS</a>
                                  
 
            
                                                                     <ul id="drop-nav-contests" data-dropdown-content aria-autoclose="false" class="f-dropdown content">
                                                                    
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/kamc-wwe-live-giveaway">KAMC WWE LIVE TICKET GIVEAWAY</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/klbk-wwe-live-giveaway">KLBK WWE LIVE TICKET GIVEAWAY</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/klbk-pro-football-challenge">KLBK PRO FOOTBALL CHALLENGE</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/kamc-pro-football-challenge">KAMC PRO FOOTBALL CHALLENGE</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/good-morning-good-coffee">GOOD MORNING GOOD COFFEE</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/klbk-a-spot-of-tea-giveaway">KLBK A SPOT OF TEA GIVEAWAY</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/klbk-rain-gauge-giveaway">KLBK RAIN GAUGE GIVEAWAY</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/rain-gauge-giveaway">KAMC RAIN GAUGE GIVEAWAY</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/klbk-auto-racing-challenge">KLBK AUTO RACING CHALLENGE</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/kamc-auto-racing-challenge">KAMC AUTO RACING CHALLENGE</a></li>
                                                                            </ul>
                                    
                                    
                                    
                                                                        
                                                                                                </li>
                                                            
                                                                                                                                                                
                                                                                    <li class="has-sub-links">
                                    <a class="accordion-toggle" data-dropdown-accordion="drop-nav-weeklyfeatures" href="#"></a>
                                                            <a href="https://www.everythinglubbock.com/news/local-news" data-dropdown="drop-nav-weeklyfeatures" data-options="is_hover:true; hover_timeout:1000">WEEKLY FEATURES</a>
                                  
 
            
                                                                     <ul id="drop-nav-weeklyfeatures" data-dropdown-content aria-autoclose="false" class="f-dropdown content">
                                                                    
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/cybersafe-parent">CYBER SAFE</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/thousandthanks">A THOUSAND THANKS</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/kamc11tues">FACT OR FIB</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/healthcast">HEALTHCAST</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/kamc-helping-hands">KAMC HELPING HANDS</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/kiss-the-cook">KISS THE COOK</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/talking-points">TALKING POINTS</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/kamctues">TECHNOLOGY TUESDAY</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/uniquely-west-texas">UNIQUELY WEST TEXAS</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/kamcwed">WISH WEDNESDAY</a></li>
                                                                            </ul>
                                    
                                    
                                    
                                                                        
                                                                                                </li>
                                                            
                                                                                                                                                                
                                                                                    <li class="has-sub-links">
                                    <a class="accordion-toggle" data-dropdown-accordion="drop-nav-aboutus" href="#"></a>
                                                            <a href="https://www.everythinglubbock.com/contact-us" data-dropdown="drop-nav-aboutus" data-options="is_hover:true; hover_timeout:1000">ABOUT US</a>
                                  
 
            
                                                                     <ul id="drop-nav-aboutus" data-dropdown-content aria-autoclose="false" class="f-dropdown content">
                                                                    
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/closed-captioning-concerns">CLOSED CAPTION CONCERNS</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/about-us/klbk-news-team">MEET THE KLBK TEAM</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/about-us/kamc-news-team">MEET THE KAMC TEAM</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/contact-us">CONTACT US</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/work-for-us">WORK FOR US</a></li>
                                                                            </ul>
                                    
                                    
                                    
                                                                        
                                                                                                </li>
                                                            
                                                                                                                                                                
                                                                                    <li class="has-sub-links">
                                    <a class="accordion-toggle" data-dropdown-accordion="drop-nav-everythinglubbock" href="#"></a>
                                                            <a href="https://www.everythinglubbock.com/news/local-news" data-dropdown="drop-nav-everythinglubbock" data-options="is_hover:true; hover_timeout:1000">EVERYTHING LUBBOCK</a>
                                  
 
            
                                                                     <ul id="drop-nav-everythinglubbock" data-dropdown-content aria-autoclose="false" class="f-dropdown content">
                                                                    
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/west-texas-jobs">WEST TEXAS JOBS</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/hidden-history">HIDDEN HISTORY</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/community1">HOME IMPROVEMENT</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/health-resource-center">HEALTH RESOURCE CENTER</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/browse-digital-life">DIGITAL LIFE</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/lottery">LOTTERY</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/horoscopes">HOROSCOPES</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/calendar">CALENDAR</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/gas-tracker">GAS TRACKER</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/pothole-locator">POTHOLE LOCATOR</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/notextwtx">NO TEXT WEST TEXAS</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/community/movies">MOVIES</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/hooked-on-science">HOOKED ON SCIENCE</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/coupons">COUPONS AND SAVINGS</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/marketplace/everythinglubbockmobile">MOBILE</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/tv-schedule1">TV SCHEDULE</a></li>
                                                                                                                                                                                                                                                                            <li><a href="https://www.everythinglubbock.com/alexa">ALEXA</a></li>
                                                                            </ul>
                                    
                                    
                                    
                                                                        
                                                                                                </li>
                                                            
                                                                                                                                                                <li><a href="https://www.everythinglubbock.com/tv-schedule1">TV SCHEDULE</a></li>
                                                </ul>
                                        <div class="site-search show-for-large-up">
                    <a href="#" class="button" data-dropdown="drop-search" data-options="is_hover:true; hover_timeout:5000"><i class="fa fa-search"></i></a>
                    <form id="drop-search" data-dropdown-content aria-autoclose="false" class="f-dropdown content align-right">
                        <input type="text" placeholder="Site Search..." id="site-search__field"/> <a href="#" class="button" id="site-search__button">Search</a> </form> <script>/*<![CDATA[*/(function(b,a){window.setTimeout(function(){b("#site-search__button").click(function(d){d.preventDefault();var c=b("#site-search__field").val().trim();if(c!==""){window.location="/search?q="+c}});b("#site-search__field").keydown(function(d){if(d.keyCode===13){d.preventDefault();var c=b("#site-search__field").val().trim();if(c!==""){window.location="/search?q="+c}}})},0)})(jQuery,AUI());/*]]>*/</script> </div> </div> </div> </nav> </header> <!-- end: HEADER --> <div id="main" class="container" data-role="content"> <div id="p_p_id_103_" class="portlet-boundary portlet-boundary_103_ portlet-static portlet-static-end portlet-borderless " > <span id="p_103"></span> <div class="portlet-body"> </div> </div> <div class="nxs-amino-layout" id="main-content" role="main"> <section class="row-wrapper"> <div class="portlet-layout row"> <div class="portlet-column column large-12" id="column-1"> <div class="portlet-dropzone portlet-column-content" id="layout-column_column-1"> <div id="p_p_id_56_INSTANCE_9942_" class="portlet-boundary portlet-boundary_56_ portlet-static portlet-static-end portlet-borderless portlet-journal-content " > <span id="p_56_INSTANCE_9942"></span> <div class="portlet-body"> <div class="portlet-borderless-container " style=""> <div class="portlet-body"> <div class="journal-content-article" id="article_10155_54787063_MOD-AMINO-BILLBOARD-AD_1.0"> <!-- Begin: Ad --> <section class="module mod-wrapper mod-ad "> <div id="billboard1-125518" class="ep-ad-slot mod-body billboard1" data-ad-json='{"baseAdUnitPath":"nx.klbk","contentId":"","isCompanion":true,"isOOP":false,"networkID":"5678","disableRefreshOnResize":false,"siteKey":"","size":[[970, 250], [970, 90], [970, 30], [728, 90]],"lazyLoadDisabled":false,"moduleRefreshable":true,"pos":"billboard1","wxTargeting":{"skycond":"","temp":"","svwx":false,"sclose":false,"precip":"0"}}'></div> <script type="text/javascript">/*<![CDATA[*/if(EP&&EP.Utils&&EP.Utils.AdUtils){EP.Utils.AdUtils.registerAd("billboard1-125518")};/*]]>*/</script> </section> <!-- End: Ad --> </div> </div> </div> </div> </div> </div> </div> </div> <div class="portlet-layout row"> <div class="portlet-column column large-8" id="column-2"> <div class="portlet-dropzone portlet-column-content" id="layout-column_column-2"> <div id="p_p_id_101_INSTANCE_9vk2T4Pg4hCn_" class="portlet-boundary portlet-boundary_101_ portlet-static portlet-static-end portlet-borderless portlet-asset-publisher " > <span id="p_101_INSTANCE_9vk2T4Pg4hCn"></span> <div class="portlet-body"> <div class="portlet-borderless-container " style=""> <div class="portlet-body"> <div> <div class="asset-full-content default-asset-publisher no-title"> <div class="asset-content"> <div class="journal-content-article"> <!--altest ENABLED --> <!-- story begins --> <div class="portlet-boundary"> <script type='text/javascript'> var _sf_async_config={}; /** CONFIGURATION START **/ _sf_async_config.uid = 23192; _sf_async_config.domain = 'everythinglubbock.com'; _sf_async_config.useCanonical = true; _sf_async_config.sections = ('story' == 'feed-story'? 'story' : 'story'); _sf_async_config.authors = 'News Release & Posted By Staff | newsweb@everythinglubbock.com '; /** CONFIGURATION END **/ (function(){ function loadChartbeat() { window._sf_endpt=(new Date()).getTime(); var e = document.createElement('script'); e.setAttribute('language', 'javascript'); e.setAttribute('type', 'text/javascript'); e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js'); document.body.appendChild(e); } var oldonload = window.onload; window.onload = (typeof window.onload != 'function') ? loadChartbeat : function() { oldonload(); loadChartbeat(); }; })(); </script> <section class="module mod-story "> <header class="mod-header"> <a href="/news/local-news" class="category">Local News</a> <h1 class="headline">Buddy Holly: Life, Legend, Legacy</h1> <h2 class="sub-headline">Texas Tech University's Southwest Collection/Special Collections Library</h2> <div class="meta-share"> <div class="story-meta"> <span class="author-by">By: </span> <ul class="author-list multiple"> <li class="author"> <a href="">News Release & Posted By Staff | newsweb@everythinglubbock.com </a> </li> </ul> <div class="time"> <p class="posted"><strong>Posted:</strong> Sep 02, 2018 11:11 AM CDT</p> <p class="updated"><strong>Updated:</strong> Sep 02, 2018 12:18 PM CDT</p> </div> </div> <div class="addthis_sharing_toolbox addthis_inline_share_toolbox social-share"></div> <script type="text/javascript">/*<![CDATA[*/$(".addthis_sharing_toolbox").each(function(){});/*]]>*/</script> </div> </header> <div class="mod-content"> <aside class="mod-inline media "> <figure class="crop-photo image" style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2017/01/29/Story_799443_ver1.0_1485717577911_16867844_ver1.0_640_360.jpg');"> <div class="image-wrapper"> <a class="add-magnify-icon" href="#" data-reveal-id="modal-magnify-photo-"> <img src="https://www.everythinglubbock.com/nxs-main-v2-theme/images/placeholder/placeholder-16x9.jpg" alt="Buddy Holly: Life, Legend, Legacy"> <small class="copyright"></small> </a> </div> <figcaption><p>(Photo provided by the Buddy Holly Center)</p></figcaption> </figure> </aside> <div id="modal-magnify-photo-" class="reveal-modal" data-reveal="" aria-labelledby="modalTitle" aria-hidden="true" role="dialog"> <figure class="media"> <div class="image-wrapper"> <img src="https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2017/01/29/Story_799443_ver1.0_1485717577911_16867844_ver1.0_640_360.jpg" alt="Buddy Holly: Life, Legend, Legacy"> <small class="copyright"></small> </div> <figcaption><p>(Photo provided by the Buddy Holly Center)</p></figcaption> </figure> <a class="close-reveal-modal" aria-label="Close"><i class="fa fa-close"></i></a> </div> <!-- Geocode starts --> <div id="drop-geocode" data-dropdown-content="" class="f-dropdown content medium" aria-hidden="true" tabindex="-1"> <div class="responsive-wrapper r4x3 no-controls"> <iframe src="https://www.google.com/maps/embed/v1/place?key=AIzaSyCqQrDUPuDj3ncgkZUe1y7KTtvUN63MWAc&q=," width="400" height="300" frameborder="0" style="border:0" allowfullscreen=""></iframe> </div> </div> <!-- Geocode ends --> <!-- related story headlines starts --> <!-- related story headlines ends --> <!-- related story headlines starts --> <!-- begin: RELATED STORIES FLOAT RIGHT--> <aside class="mod-inline headlines right"> <h4>Local News</h4> <ul class="list bullets"> <li> <div class="headline-wrapper"> <h4><a href="/news/local-news/non-bankruptcy-reagor-dykes-companies-might-file-chapter-11-court-records-say/1409653287">Non-bankruptcy Reagor Dykes companies might file chapter 11, court records say</a></h4> </div> </li> <li> <div class="headline-wrapper"> <h4><a href="/news/local-news/lubbock-reports-improved-save-rate/1409547108">Lubbock reports improved save rate at animal shelter</a></h4> </div> </li> <li> <div class="headline-wrapper"> <h4><a href="/news/local-news/reagor-dykes-statement-after/1407733183">Reagor Dykes statement after Thursday bankruptcy hearing</a></h4> </div> </li> <li> <div class="headline-wrapper"> <h4><a href="/news/local-news/group-says-unsafe-bacteria-found-in-brazos-tributary-in-lubbock/1407340733">Group says unsafe bacteria found in Brazos tributary in Lubbock</a></h4> </div> </li> </ul> </aside> <!-- end: RELATED STORIES FLOAT RIGHT--> <!-- related story headlines ends --> <!-- story body starts --> <p>LUBBOCK, Texas (NEWS RELEASE) - <em>The following is a news release from Texas Tech University:</em></p><p>Lubbock&rsquo;s favorite music son, Buddy Holly, will be featured in a new exhibit at the&nbsp;Texas Tech University Southwest Collection/Special Collections Library, with a reception and gallery talk for the exhibit at 5 p.m. on Sept. 6.</p><p>Parking is available in the lot west of the SWC/SCL, located at 15<sup>th&nbsp;</sup>Street and Detroit Avenue on the Texas Tech campus. Additional park-and-pay spaces are available in the lot south of the Student Union Building. The public is invited to attend and admission is free.</p><p>Since his meteoric rise to fame in the late 1950s and untimely death in a plane crash in 1959, Holly&rsquo;s career has been celebrated globally. The exhibit contains photos, posters, ephemera and artifacts from one of his biggest fans, Bill Griggs. The Bill Griggs Collection is part of the&nbsp;Crossroads of Music Archive&nbsp;in the SWC/SCL.</p><p>Griggs is a Connecticut native who grew up devoted to astronomy, steamship travel, hot rods and radio in all its forms.</p><p>&ldquo;A particular fan of disc jockey &lsquo;Moondog&rsquo; Alan Freed, he attended one of the DJs &lsquo;Big Beat&rsquo; shows and saw Buddy Holly perform with the Crickets in Hartford on March 30, 1958,&rdquo; said Curtis Peoples, archivist for the SWC/SCL&rsquo;s Crossroads of Music Archive.</p><p>When Holly died on Feb. 3, 1959, Griggs began collecting everything he could find, Peoples said. While managing a K-Mart and a 1950s memorabilia mail-order business, he launched the Buddy Holly Memorial Society in 1975 and its quarterly journal Reminiscing. The Buddy Holly Memorial Society hosted its first convention in 1977 with a Crickets reunion concert.</p><p>Griggs subsequently published and consulted on a number of books, articles, TV shows and liner notes for recordings. In 1981 he and The Buddy Holly Memorial Society relocated to Lubbock. He began producing music events in Lubbock and Clovis, New Mexico. For two years he ran a rock revival music show on KDAV-AM radio. Eventually, the society, licensed by the Holly estate, enrolled more than 5,500 members from all 50 states and 34 nations, Peoples said.</p><p>Griggs published for 30 years and produced 11 consecutive Buddy Holly Memorial Society conventions, as well as serving as master of ceremonies for countless annual reunions at the Surf Ballroom in Clear Lake, Iowa, site of the final concert before &ldquo;the music died.&rdquo; Griggs died in Lubbock on March 29, 2011.</p><p>The Bill Griggs Collection was donated to the Crossroads of Music Archive by Texas Tech alumnus Randy Steele, who was placed in charge of caring for the collection after Griggs&rsquo; death. Peoples and Steele met and discovered common threads in their passion for Holly nostalgia and the result was the donation of the collection to the SWC/SCL for public research and exhibition. The exhibit will be showcased at the Buddy Holly Center in 2019.</p><p><u>CONTACT</u><b>: </b><br /> Curtis Peoples, archivist, Crossroads of Music Archive, Southwest Collection/Special Collections Library, Texas Tech University,&nbsp;(806) 834-5777 or&nbsp;<a data-auth="NotApplicable" href="mailto:curtis.peoples@ttu.edu" rel="noopener noreferrer" target="_blank">curtis.peoples@ttu.edu</a></p><p>(News release from Texas Tech University)</p> <!-- story body ends --> <div class="pagination-centered"> <ul class="pagination"> </ul> </div> </div> <footer class="mod-footer"> <div class="footer-text"> <p class="copyright">Copyright 2018 Nexstar Broadcasting, Inc. All rights reserved. This material may not be published, broadcast, rewritten, or redistributed.</p> </div> <div class="addthis_sharing_toolbox addthis_inline_share_toolbox social-share"></div> <script type="text/javascript">/*<![CDATA[*/$(".addthis_sharing_toolbox").each(function(){});/*]]>*/</script> </footer> </section> </div> <!-- story ends --> <script>/*<![CDATA[*/$(function(){var a=$(".pagination-centered > .pagination > li > a");a.click(function(n){n.preventDefault();var u=$(this);var o=$(".tabs-content > .content.active");var v=u.attr("href").substring(1);var k=$("#"+v);var w=$(".pagination-centered > .pagination > .current");var t=u.parent();var h=t.attr("class");var l=Number("1");if(h&&h.indexOf("unavailable")>=0){}else{if(h&&h.indexOf("arrow")>=0){var s=Number(w.find("a:first").html());var e=u.find("i").attr("class").indexOf("left")>=0?true:false;if(e){if(s>1){var j=s-1;v="page_"+j;var c=$("#"+v);if(l>6){var f=j;var q=j+1;var p=j+2;var m=j+3;var b=t.parent().find("li > a");var g=Number(b.eq(1).html());if(g&&s<=g){b.eq(1).html(f);b.eq(1).attr("href","#page_"+f);b.eq(2).html(q);b.eq(2).attr("href","#page_"+q);b.eq(3).html(p);b.eq(3).attr("href","#page_"+p);b.eq(4).html(m);b.eq(4).attr("href","#page_"+m);if(s==l-5){b.eq(5).attr("style","display: block")}}}var d=$("ul[class='pagination'] > li > a[href='#"+v+"']").parent();o.attr("class","content");w.attr("class","");c.attr("class","content active");d.attr("class","current");if(s==2){t.parent().find("li[class='arrow']:first").attr("class","arrow unavailable")}if(s==l){t.parent().find("li[class='arrow unavailable']").attr("class","arrow")}}}else{if(s<l){var j=s+1;v="page_"+j;var c=$("#"+v);if(l>6){var f=s-2;var q=s-1;var p=s;var m=j;var b=t.parent().find("li > a");if(s>=4&&s<=l-3){b.eq(1).html(f);b.eq(1).attr("href","#page_"+f);b.eq(2).html(q);b.eq(2).attr("href","#page_"+q);b.eq(3).html(p);b.eq(3).attr("href","#page_"+p);b.eq(4).html(m);b.eq(4).attr("href","#page_"+m);if(s==l-3){b.eq(5).attr("style","display: none")}}}var d=$("ul[class='pagination'] > li > a[href='#"+v+"']").parent();o.attr("class","content");w.attr("class","");c.attr("class","content active");d.attr("class","current");if(s==(l-1)){t.parent().find("li[class='arrow']:last").attr("class","arrow unavailable")}if(s==1){t.parent().find("li[class='arrow unavailable']").attr("class","arrow")}}}$("html, body").animate({scrollTop:0},"slow")}else{o.attr("class","content");w.attr("class","");k.attr("class","content active");t.attr("class","current");var r=Number(u.html());var i=t.parent().find("li[class='arrow unavailable']");if(r==1){if(i){i.attr("class","arrow")}t.parent().find("li[class='arrow']:first").attr("class","arrow unavailable")}else{if(r>=l-1){if(i){i.attr("class","arrow")}var b=t.parent().find("li > a");var g=Number(b.eq(1).html());if(l>6&&g<=l-6){var f=l-5;var q=l-4;var p=l-3;var m=l-2;b.eq(1).html(f);b.eq(1).attr("href","#page_"+f);b.eq(2).html(q);b.eq(2).attr("href","#page_"+q);b.eq(3).html(p);b.eq(3).attr("href","#page_"+p);b.eq(4).html(m);b.eq(4).attr("href","#page_"+m);b.eq(5).attr("style","display: none")}if(r==l){t.parent().find("li[class='arrow']:last").attr("class","arrow unavailable")}}else{if(i){i.attr("class","arrow")}}}$("html, body").animate({scrollTop:0},"slow")}}})});/*]]>*/</script> <script>/*<![CDATA[*/$(document).ready(function(){var g=(function(){var i=navigator.userAgent.toLowerCase();var j={IOS:/ipod|iphone|ipad/.test(i),IPHONE:/iphone/.test(i),IPAD:/ipad/.test(i),ANDROID:/android/.test(i),WINDOWS:/windows/.test(i),TOUCH_DEVICE:("ontouchstart" in window)||/touch/.test(i),MOBILE:/mobile/.test(i),ANDROID_TABLET:false,WINDOWS_TABLET:false,TABLET:false,SMART_DEVICE:false,SMART_PHONE:false};j.ANDROID_TABLET=j.ANDROID&&!j.MOBILE;j.WINDOWS_TABLET=j.WINDOWS&&/tablet/.test(i);j.TABLET=j.IPAD||j.ANDROID_TABLET||j.WINDOWS_TABLET;j.SMART_PHONE=j.MOBILE&&!j.TABLET;j.SMART_DEVICE=j.MOBILE||j.TABLET;console.log("DEVICE INFO:");console.log(j);return j}());if(!g.SMART_DEVICE){var b=3,e=$(".mod-story .mod-content p:not(.media p)"),d=e.length,h=75,f=0;if(d>=b){for(var c=0;c<d;c++){var a=$(e[c]).text().length;if(a>h){f++}if(f===b){$("<div id='lkqd-ad-476-683831-outstream-incontent-1413273764'></div>").insertAfter(e[c]);break}}}else{if(d>0){$("<div id='lkqd-ad-476-683831-outstream-incontent-1413273764'></div>").insertAfter(e[d-1])}}(function(){var l={pid:476,sid:683831,playerContainerId:"lkqd-ad-476-683831-outstream-incontent-1413273764",playerId:"",playerWidth:"",playerHeight:"",execution:"outstream",placement:"incontent",playInitiation:"auto",controls:true,volume:0,pageUrl:"",trackImp:"",trackClick:"",custom1:"",custom2:"",custom3:"",pubMacros:"",dfp:false,lkqdId:new Date().getTime().toString()+Math.round(Math.random()*1000000000).toString()};var k;var o="";var m={slot:document.getElementById(l.playerContainerId),videoSlot:document.getElementById(l.playerId),videoSlotCanAutoPlay:true,lkqdSettings:l};function j(){k.subscribe(function(){k.startAd()},"AdLoaded")}var n=document.createElement("iframe");n.id=l.lkqdId;n.name=l.lkqdId;n.style.display="none";var i=function(){vpaidLoader=n.contentWindow.document.createElement("script");vpaidLoader.src="https://ad.lkqd.net/vpaid/formats.js?pid=476&sid=683831";vpaidLoader.onload=function(){k=n.contentWindow.getVPAIDAd();j();k.handshakeVersion("2.0");k.initAd(l.playerWidth,l.playerHeight,"normal",600,o,m)};n.contentWindow.document.body.appendChild(vpaidLoader)};n.onload=i;n.onerror=i;document.documentElement.appendChild(n)})()}});/*]]>*/</script> </div> <br /> </div> <div class="asset-metadata"> </div> </div> </div> </div> </div> </div> </div> <div id="p_p_id_56_INSTANCE_7YZl9JcCZKtW_" class="portlet-boundary portlet-boundary_56_ portlet-static portlet-static-end portlet-borderless portlet-journal-content " > <span id="p_56_INSTANCE_7YZl9JcCZKtW"></span> <div class="portlet-body"> <div class="portlet-borderless-container " style=""> <div class="portlet-body"> <div class="journal-content-article" id="article_10155_54787063_1094693834_1.0"> <div id="lkqd-outstream"></div> </div> </div> </div> </div> </div> <div id="p_p_id_56_INSTANCE_6700_" class="portlet-boundary portlet-boundary_56_ portlet-static portlet-static-end portlet-borderless portlet-journal-content " > <span id="p_56_INSTANCE_6700"></span> <div class="portlet-body"> <div class="portlet-borderless-container " style=""> <div class="portlet-body"> <div class="journal-content-article" id="article_10155_54787063_MOD-EVERYTHINGLUBBOCK-RELATED_STORIES_1.0"> <!-- begin: RELATED CONTENT --> <section class="module mod-media-grid border"> <header class="mod-header"> <h3>More Stories</h3> </header> <div class="mod-content"> <ul class="list media small-block-grid-1 medium-block-grid-3"> <li> <div class="image-wrapper"> <a href="/news/local-news/man-arrested-in-fatal-hit-and-run-crash-in-plainview-late-friday-evening/1412265577" title="Man arrested for fatal hit-and-run crash in Plainview late Friday evening"> <figure class="crop-photo image" style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2018/09/01/AsimDizdarevic720_1535845727939_53906822_ver1.0_320_240.jpg');"> <img src="//static.lakana.com/nxsglobal/global/theme/images/placeholder/placeholder-16x9.jpg" alt="Asim Dizdarevic (Photo provided by the Hale County Sheriff's Office)"> </figure> <h4 class="headline overlay">Man arrested for fatal hit-and-run crash in Plainview late Friday evening</h4> </a> </div> <div class="headline-wrapper"> <p><p>The accident was reported around 10:15 p.m. in the 900 block of South&hellip;</p> <time class="update" datatime="">18 hours ago</time> </div> </li> <li> <div class="image-wrapper"> <a href="/news/local-news/reminder-city-of-lubbock-offices-closed-monday-september-3-2018-for-the-labor-day-holiday/1413386434" title="Reminder: City of Lubbock offices closed Monday, September 3 for the&hellip;"> <figure class="crop-photo image" style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2015/08/30/White%20Background_1440957046180_4630327_ver1.0_320_240.jpg');"> <img src="//static.lakana.com/nxsglobal/global/theme/images/placeholder/placeholder-16x9.jpg" alt="(Photo provided by the City of Lubbock)"> </figure> <h4 class="headline overlay">Reminder: City of Lubbock offices closed Monday, September 3 for the&hellip;</h4> </a> </div> <div class="headline-wrapper"> <p><p>Regular business hours and city services will resume on Tuesday,&hellip;</p> <time class="update" datatime="">36 minutes ago</time> </div> </li> <li> <div class="image-wrapper"> <a href="/news/local-news/medicare-part-d-open-enrollment-presentations-scheduled-in-september-october/1413375681" title="Medicare Part D open enrollment presentations scheduled in September, October"> <figure class="crop-photo image" style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2018/09/02/Health%20News%2C%20Caduceus%20-%20720_1535909099213.jpg_53968105_ver1.0_320_240.jpg');"> <img src="//static.lakana.com/nxsglobal/global/theme/images/placeholder/placeholder-16x9.jpg" alt="(Photo from MGN Online)"> </figure> <h4 class="headline overlay">Medicare Part D open enrollment presentations scheduled in September, October</h4> </a> </div> <div class="headline-wrapper"> <p><p>For more information on Medicare Part D Open Enrollment, visit&hellip;</p> <time class="update" datatime="">41 minutes ago</time> </div> </li> </ul> </div> </section> <!-- end: RELATED CONTENT --> </div> </div> </div> </div> </div> </div> <section class="portlet-layout row"> <div class="portlet-column column medium-6 large-6" id="column-3"> <div class="portlet-dropzone empty portlet-column-content" id="layout-column_column-3"></div> </div> <div class="portlet-column column medium-6 large-6" id="column-4"> <div class="portlet-dropzone empty portlet-column-content" id="layout-column_column-4"></div> </div> </section> </div> <div class="portlet-column column large-4" id="column-5"> <div class="portlet-dropzone portlet-column-content" id="layout-column_column-5"> <div id="p_p_id_56_INSTANCE_7893_" class="portlet-boundary portlet-boundary_56_ portlet-static portlet-static-end portlet-borderless portlet-journal-content " > <span id="p_56_INSTANCE_7893"></span> <div class="portlet-body"> <div class="portlet-borderless-container " style=""> <div class="portlet-body"> <div class="journal-content-article" id="article_10155_54787063_MOD-AMINO-DYNAMIC-MR-1-AD_1.0"> <!-- Begin: Ad --> <section class="module mod-wrapper mod-ad "> <div id="mr_combo1-190496" class="ep-ad-slot mod-body mr_combo1" data-ad-json='{"baseAdUnitPath":"nx.klbk","contentId":"","isCompanion":false,"isOOP":false,"networkID":"5678","disableRefreshOnResize":false,"siteKey":"","size":[[300, 250], [300, 600]],"lazyLoadDisabled":true,"moduleRefreshable":false,"pos":"mr_combo1","wxTargeting":{"skycond":"","temp":"","svwx":false,"sclose":false,"precip":"0"}}'></div> <script type="text/javascript">/*<![CDATA[*/if(EP&&EP.Utils&&EP.Utils.AdUtils){EP.Utils.AdUtils.registerAd("mr_combo1-190496")};/*]]>*/</script> </section> <!-- End: Ad --> </div> </div> </div> </div> </div> <div id="p_p_id_56_INSTANCE_fEq1SSBStHnQ_" class="portlet-boundary portlet-boundary_56_ portlet-static portlet-static-end portlet-borderless portlet-journal-content " > <span id="p_56_INSTANCE_fEq1SSBStHnQ"></span> <div class="portlet-body"> <div class="portlet-borderless-container " style=""> <div class="portlet-body"> <div class="journal-content-article" id="article_10155_54787063_MOD-AMINO-MEDIA-HEADLINE-LIST-TO-CAROUSE-DONTMISS-STORY-PAGE_1.0"> <!-- begin: CAROUSEL --> <div> <section class="module mod-carousel block-grid border no-carousel-buttons"> <header class="mod-header"> <h2>Don't Miss</h2> </header> <div class="mod-content"> <div id="amino-carousel-76143" class="owl-carousel owl-theme no-wrap-headline"> <div class="item"> <div class="image-wrapper"> <a href="http://www.everythinglubbock.com/klbk-pro-football-challenge"> <figure class="crop-photo image " style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2018/08/24/Pro-Football-Challenge-KLBK-Dont-Miss-IMAGE-2018_1535142317936_52983525_ver1.0_320_180.jpg');"> <img src="https://www.everythinglubbock.com/nxs-main-v2-theme/images/placeholder/placeholder-16x9.jpg" alt="KLBK Pro Football Challenge"> </figure> </a> <small class="copyright">Copyright 2018 Nexstar Broadcasting, Inc. All rights reserved. This material may not be published, broadcast, rewritten, or redistributed.</small> </div> <div class="headline-wrapper "> <h4 class="headline"> <a href="http://www.everythinglubbock.com/klbk-pro-football-challenge" > KLBK Pro Football Challenge </a> </h4> </div> </div> <div class="item"> <div class="image-wrapper"> <a href="http://www.everythinglubbock.com/kamc-pro-football-challenge"> <figure class="crop-photo image " style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2018/08/24/Pro-Football-Challenge-KAMC-Dont-Miss-IMAGE-2018_1535142389031_52983530_ver1.0_320_180.jpg');"> <img src="https://www.everythinglubbock.com/nxs-main-v2-theme/images/placeholder/placeholder-16x9.jpg" alt="KAMC Pro Football Challenge"> </figure> </a> <small class="copyright">Copyright 2018 Nexstar Broadcasting, Inc. All rights reserved. This material may not be published, broadcast, rewritten, or redistributed.</small> </div> <div class="headline-wrapper "> <h4 class="headline"> <a href="http://www.everythinglubbock.com/kamc-pro-football-challenge" > KAMC Pro Football Challenge </a> </h4> </div> </div> <div class="item"> <div class="image-wrapper"> <a href="http://www.everythinglubbock.com/klbk-rain-gauge-giveaway"> <figure class="crop-photo image " style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2018/07/09/KLBK-Rain-Gauge-Giveaway-2018-FB-Image_1531168669468_48113530_ver1.0_320_180.jpg');"> <img src="https://www.everythinglubbock.com/nxs-main-v2-theme/images/placeholder/placeholder-16x9.jpg" alt="KLBK Rain Gauge Giveaway"> </figure> </a> <small class="copyright"></small> </div> <div class="headline-wrapper "> <h4 class="headline"> <a href="http://www.everythinglubbock.com/klbk-rain-gauge-giveaway" > KLBK Rain Gauge Giveaway </a> </h4> </div> </div> <div class="item"> <div class="image-wrapper"> <a href="http://www.everythinglubbock.com/rain-gauge-giveaway"> <figure class="crop-photo image " style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2018/04/19/KAMC-Rain-Gauge-Giveaway-2018-Don%27t-Miss_1524146430215_40144169_ver1.0_320_180.jpg');"> <img src="https://www.everythinglubbock.com/nxs-main-v2-theme/images/placeholder/placeholder-16x9.jpg" alt="KAMC Rain Gauge Giveaway"> </figure> </a> <small class="copyright"></small> </div> <div class="headline-wrapper "> <h4 class="headline"> <a href="http://www.everythinglubbock.com/rain-gauge-giveaway" > KAMC Rain Gauge Giveaway </a> </h4> </div> </div> <div class="item"> <div class="image-wrapper"> <a href="http://www.everythinglubbock.com/klbk-auto-racing-challenge"> <figure class="crop-photo image " style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2018/04/27/Auto-Racing-Challenge-FB-Image-A-KLBK_1524865197365_40996163_ver1.0_320_180.jpg');"> <img src="https://www.everythinglubbock.com/nxs-main-v2-theme/images/placeholder/placeholder-16x9.jpg" alt="KLBK Auto Racing Challenge"> </figure> </a> <small class="copyright"></small> </div> <div class="headline-wrapper "> <h4 class="headline"> <a href="http://www.everythinglubbock.com/klbk-auto-racing-challenge" > KLBK Auto Racing Challenge </a> </h4> </div> </div> <div class="item"> <div class="image-wrapper"> <a href="http://www.everythinglubbock.com/kamc-auto-racing-challenge"> <figure class="crop-photo image " style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2018/04/27/Auto-Racing-Challenge-FB-Image-B-KAMC_1524865197374_40996162_ver1.0_320_180.jpg');"> <img src="https://www.everythinglubbock.com/nxs-main-v2-theme/images/placeholder/placeholder-16x9.jpg" alt="KAMC Auto Racing Challenge"> </figure> </a> <small class="copyright"></small> </div> <div class="headline-wrapper "> <h4 class="headline"> <a href="http://www.everythinglubbock.com/kamc-auto-racing-challenge" > KAMC Auto Racing Challenge </a> </h4> </div> </div> <div class="item"> <div class="image-wrapper"> <a href="http://www.everythinglubbock.com/klbk-a-spot-of-tea-giveaway"> <figure class="crop-photo image " style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2017/09/21/KLBK-A-Spot-Of-Tea-Giveaway-Dont-Miss_1506026365058_26678832_ver1.0_320_180.jpg');"> <img src="https://www.everythinglubbock.com/nxs-main-v2-theme/images/placeholder/placeholder-16x9.jpg" alt="KLBK's A Spot Of Tea Giveaway"> </figure> </a> <small class="copyright"></small> </div> <div class="headline-wrapper "> <h4 class="headline"> <a href="http://www.everythinglubbock.com/klbk-a-spot-of-tea-giveaway" > KLBK's A Spot Of Tea Giveaway </a> </h4> </div> </div> <div class="item"> <div class="image-wrapper"> <a href="http://www.everythinglubbock.com/sports/red-raider-nation"> <figure class="crop-photo image " style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2015/06/19/redraidernation_1434723501636_1582031_ver1.0_320_180.png');"> <img src="https://www.everythinglubbock.com/nxs-main-v2-theme/images/placeholder/placeholder-16x9.jpg" alt="Red Raider Nation"> </figure> </a> <small class="copyright"></small> </div> <div class="headline-wrapper "> <h4 class="headline"> <a href="http://www.everythinglubbock.com/sports/red-raider-nation" > Red Raider Nation </a> </h4> </div> </div> <div class="item"> <div class="image-wrapper"> <a href="http://www.everythinglubbock.com/community/movies"> <figure class="crop-photo image " style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2016/06/09/movielisting_v2_DontMiss_1465489713076_8925432_ver1.0_320_180.png');"> <img src="https://www.everythinglubbock.com/nxs-main-v2-theme/images/placeholder/placeholder-16x9.jpg" alt="Movie Listings"> </figure> </a> <small class="copyright"></small> </div> <div class="headline-wrapper "> <h4 class="headline"> <a href="http://www.everythinglubbock.com/community/movies" > Movie Listings </a> </h4> </div> </div> <div class="item"> <div class="image-wrapper"> <a href="http://www.everythinglubbock.com/talking-points"> <figure class="crop-photo image " style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2015/11/02/TalkingPoints_DontMiss_5410531_ver1.0_320_180.jpg');"> <img src="https://www.everythinglubbock.com/nxs-main-v2-theme/images/placeholder/placeholder-16x9.jpg" alt="Talking Points"> </figure> </a> <small class="copyright"></small> </div> <div class="headline-wrapper "> <h4 class="headline"> <a href="http://www.everythinglubbock.com/talking-points" > Talking Points </a> </h4> </div> </div> </div> </div> <script type="text/javascript">/*<![CDATA[*/$(document).ready(function(){var f=$("#amino-carousel-76143");var e=false;var b=1;var d=[640,1];var c=false;if(true){e=4000?4000:true}var a=false;f.owlCarousel({items:b,scrollPerPage:true,navigation:true,itemsDesktop:false,itemsDesktopSmall:false,itemsTablet:c,itemsMobile:d,paginationNumbers:a,autoPlay:e})});/*]]>*/</script> </section> </div> <!-- end: CAROUSEL --> </div> </div> </div> </div> </div> <div id="p_p_id_56_INSTANCE_8763_" class="portlet-boundary portlet-boundary_56_ portlet-static portlet-static-end portlet-borderless portlet-journal-content " > <span id="p_56_INSTANCE_8763"></span> <div class="portlet-body"> <div class="portlet-borderless-container " style=""> <div class="portlet-body"> <div class="journal-content-article" id="article_10155_54787063_1094693847_1.0"> <div id="native-rr"></div> </div> </div> </div> </div> </div> <div id="p_p_id_56_INSTANCE_Xzo6BJEInqK3_" class="portlet-boundary portlet-boundary_56_ portlet-static portlet-static-end portlet-borderless portlet-journal-content " > <span id="p_56_INSTANCE_Xzo6BJEInqK3"></span> <div class="portlet-body"> <div class="portlet-borderless-container " style=""> <div class="portlet-body"> <div class="journal-content-article" id="article_10155_54787063_1262061151_1.0"> <section class="module mod-headline-list"> <header class="mod-header popular"> <h2>Trending Stories</h2> </header> <div id="content-mod-headline-list-1262061151" class="mod-content"> </div> </section> <script>/*<![CDATA[*/(function(d,a){var b="/home?p_p_id=refresharticle_WAR_epwcmportlet&p_p_lifecycle=2&p_p_cacheability=cacheLevelPage&_refresharticle_WAR_epwcmportlet_groupId=54787063&_refresharticle_WAR_epwcmportlet_articleId=1262061151&_refresharticle_WAR_epwcmportlet_templateId=AMINO_HEADLINE_LIST_CHARTBEAT&displayNumber=5&categories=";var c=d("#content-mod-headline-list-1262061151");c.empty();c.append("<div id='loader--mod-headline-list-1262061151' class='loader'><img src='https://www.everythinglubbock.com/nxs-main-v2-theme/images/loader.gif' alt='Loading'></div>");d.ajax({type:"GET",url:b}).done(function(e){d("#loader--mod-headline-list-1262061151").remove();var f=d(e.trim());c.append(f)}).fail(function(){d("#loader--mod-headline-list-1262061151").remove();c.append("<p class='text-center'>Oops. Something went wrong. Please wait a minute and refresh your browser.</p>")})})(jQuery,AUI());/*]]>*/</script> <script>/*<![CDATA[*/(function(b,a){b("#filter-mod-headline-list-1262061151").change(function(){var g=b(this).children("option:selected").val();var e=b(this).attr("ajaxUrl");var f=b(this).children("option:selected").attr("data-limit-number");var c=e+g;c=c.replace(/tmpLimitNum/,f);var d=b("#content-mod-headline-list-1262061151");d.empty();d.append("<div class='loader'><img src='https://www.everythinglubbock.com/nxs-main-v2-theme/images/loader.gif' alt='Loading'></div>");b.ajax({type:"GET",url:c}).done(function(h){var i=b(h);d.empty();d.append(i)}).fail(function(){d.append("<p class='text-center'>Oops. Something went wrong. Please wait a minute and refresh your browser.</p>")})})})(jQuery,AUI());/*]]>*/</script> </div> </div> </div> </div> </div> <div id="p_p_id_56_INSTANCE_0078_" class="portlet-boundary portlet-boundary_56_ portlet-static portlet-static-end portlet-borderless portlet-journal-content " > <span id="p_56_INSTANCE_0078"></span> <div class="portlet-body"> <div class="portlet-borderless-container " style=""> <div class="portlet-body"> <div class="journal-content-article" id="article_10155_54787063_MOD-EVERYTHINGLUBBOCK-TOP_STORIES_1.0"> <section class="module mod-headline-list"> <header class="mod-header"> <h2>Latest News</h2> <select id="filter-mod-filtered-story-list-MOD-EVERYTHINGLUBBOCK-TOP_STORIES" ajaxUrl="/home?p_p_id=refresharticle_WAR_epwcmportlet&p_p_lifecycle=2&p_p_cacheability=cacheLevelPage&_refresharticle_WAR_epwcmportlet_groupId=54787063&_refresharticle_WAR_epwcmportlet_articleId=MOD-EVERYTHINGLUBBOCK-TOP_STORIES&_refresharticle_WAR_epwcmportlet_templateId=AMINO_MEDIA_HEADLINE_LIST_PAGINATION&startFrom=0&displayNumber=5&tmpLimit=tmpLimitNum&autoflowId="> <option value="54800058" data-limit-number="5">Local News</option> <option value="83880038" data-limit-number="5">State & Regional</option> <option value="54800322" data-limit-number="5">National</option> </select> </header> <div id="content-mod-filtered-story-list-MOD-EVERYTHINGLUBBOCK-TOP_STORIES" class="mod-content"> <ul class="list media"> <li> <div class="image-wrapper"> <a href="/news/local-news/man-arrested-in-fatal-hit-and-run-crash-in-plainview-late-friday-evening/1412265577"><figure class="crop-photo image " style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2018/09/01/AsimDizdarevic720_1535845727939_53906822_ver1.0_320_180.jpg');"><img src="https://www.everythinglubbock.com/nxs-main-v2-theme/images/placeholder/placeholder-16x9.jpg" alt="Man arrested for fatal hit-and-run crash in Plainview late Friday evening"></figure></a> <small class="copyright"></small> </div> <div class="headline-wrapper"> <h4 > <a href="/news/local-news/man-arrested-in-fatal-hit-and-run-crash-in-plainview-late-friday-evening/1412265577" > Man arrested for fatal hit-and-run crash in Plainview late Friday evening </a> </h4> </div> </li> <li> <div class="image-wrapper"> <a href="/news/local-news/reminder-city-of-lubbock-offices-closed-monday-september-3-2018-for-the-labor-day-holiday/1413386434"><figure class="crop-photo image " style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2015/08/30/White%20Background_1440957046180_4630327_ver1.0_320_180.jpg');"><img src="https://www.everythinglubbock.com/nxs-main-v2-theme/images/placeholder/placeholder-16x9.jpg" alt="Reminder: City of Lubbock offices closed Monday, September 3 for the Labor Day holiday"></figure></a> <small class="copyright"></small> </div> <div class="headline-wrapper"> <h4 > <a href="/news/local-news/reminder-city-of-lubbock-offices-closed-monday-september-3-2018-for-the-labor-day-holiday/1413386434" > Reminder: City of Lubbock offices closed Monday, September 3 for the Labor Day holiday </a> </h4> </div> </li> <li> <div class="image-wrapper"> <a href="/news/local-news/medicare-part-d-open-enrollment-presentations-scheduled-in-september-october/1413375681"><figure class="crop-photo image " style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2018/09/02/Health%20News%2C%20Caduceus%20-%20720_1535909099213.jpg_53968105_ver1.0_320_180.jpg');"><img src="https://www.everythinglubbock.com/nxs-main-v2-theme/images/placeholder/placeholder-16x9.jpg" alt="Medicare Part D open enrollment presentations scheduled in September, October"></figure></a> <small class="copyright"></small> </div> <div class="headline-wrapper"> <h4 > <a href="/news/local-news/medicare-part-d-open-enrollment-presentations-scheduled-in-september-october/1413375681" > Medicare Part D open enrollment presentations scheduled in September, October </a> </h4> </div> </li> <li> <div class="image-wrapper"> <a href="/news/local-news/buddy-holly-center-to-host-buddy-s-82nd-birthday-bash-on-friday-september-7/1404291151"><figure class="crop-photo image " style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2017/08/26/Buddy%20Holly%20Center%20Photo%20-%20720_1503762309634_25511232_ver1.0_320_180.jpg');"><img src="https://www.everythinglubbock.com/nxs-main-v2-theme/images/placeholder/placeholder-16x9.jpg" alt="Buddy Holly Center to host Buddy's 82nd Birthday Bash on Friday, September 7"></figure></a> <small class="copyright"></small> </div> <div class="headline-wrapper"> <h4 > <a href="/news/local-news/buddy-holly-center-to-host-buddy-s-82nd-birthday-bash-on-friday-september-7/1404291151" > Buddy Holly Center to host Buddy's 82nd Birthday Bash on Friday, September 7 </a> </h4> </div> </li> <li> <div class="image-wrapper"> <a href="/news/local-news/buddy-holly-life-legend-legacy-september-2018/1413273764"><figure class="crop-photo image " style="background-image: url('https://media.everythinglubbock.com/nxsglobal/everythinglubbock/photo/2017/01/29/Story_799443_ver1.0_1485717577911_16867844_ver1.0_320_180.jpg');"><img src="https://www.everythinglubbock.com/nxs-main-v2-theme/images/placeholder/placeholder-16x9.jpg" alt="Buddy Holly: Life, Legend, Legacy"></figure></a> <small class="copyright"></small> </div> <div class="headline-wrapper"> <h4 > <a href="/news/local-news/buddy-holly-life-legend-legacy-september-2018/1413273764" > Buddy Holly: Life, Legend, Legacy </a> </h4> </div> </li> </ul> </div> </section> <script>/*<![CDATA[*/(function(b,a){b("#filter-mod-filtered-story-list-MOD-EVERYTHINGLUBBOCK-TOP_STORIES").change(function(){var g=b(this).children("option:selected").val();var e=b(this).attr("ajaxUrl");var f=b(this).children("option:selected").attr("data-limit-number");var c=e+g;c=c.replace(/tmpLimitNum/,f);var d=b("#content-mod-filtered-story-list-MOD-EVERYTHINGLUBBOCK-TOP_STORIES");d.empty();d.append("<div class='loader'><img src='https://www.everythinglubbock.com/nxs-main-v2-theme/images/loader.gif' alt='Loading'></div>");b.ajax({type:"GET",url:c}).done(function(h){var i=b(h);d.empty();d.append(i)}).fail(function(){d.append("<p class='text-center'>Oops. Something went wrong. Please wait a minute and refresh your browser.</p>")})})})(jQuery,AUI());/*]]>*/</script> </div> </div> </div> </div> </div> <div id="p_p_id_56_INSTANCE_3080_" class="portlet-boundary portlet-boundary_56_ portlet-static portlet-static-end portlet-borderless portlet-journal-content " > <span id="p_56_INSTANCE_3080"></span> <div class="portlet-body"> <div class="portlet-borderless-container " style=""> <div class="portlet-body"> <div class="journal-content-article" id="article_10155_54787063_MOD-EVERYTHINGLUBBOCK-VIDEO_CENTER_STORY_PAGE_1.0"> <section class="module mod-headline-list mod-tabs border"> <header class="mod-header"> <ul class="tabs" data-tab=""> <li class="tab-title active"><a href="#panel-localnews-mod-filtered-story-list-MOD-EVERYTHINGLUBBOCK-VIDEO_CENTER_STORY_PAGE">Local News</a></li> <li class="tab-title"><a href="#panel-nationalnews-mod-filtered-story-list-MOD-EVERYTHINGLUBBOCK-VIDEO_CENTER_STORY_PAGE">National News</a></li> </ul> </header> <div class="mod-content"> <div class="tabs-content"> <div class="content active" data-tab="tab-localnews-mod-filtered-story-list-MOD-EVERYTHINGLUBBOCK-VIDEO_CENTER_STORY_PAGE" id="panel-localnews-mod-filtered-story-list-MOD-EVERYTHINGLUBBOCK-VIDEO_CENTER_STORY_PAGE"> <ul class="list media"> </ul> </div> <div class="content" data-tab="tab-nationalnews-mod-filtered-story-list-MOD-EVERYTHINGLUBBOCK-VIDEO_CENTER_STORY_PAGE" id="panel-nationalnews-mod-filtered-story-list-MOD-EVERYTHINGLUBBOCK-VIDEO_CENTER_STORY_PAGE"> <ul class="list media"> </ul> </div> </div> </div> </section> <script>/*<![CDATA[*/(function(b,a){b("#filter-mod-filtered-story-list-MOD-EVERYTHINGLUBBOCK-VIDEO_CENTER_STORY_PAGE").change(function(){var g=b(this).children("option:selected").val();var e=b(this).attr("ajaxUrl");var f=b(this).children("option:selected").attr("data-limit-number");var c=e+g;c=c.replace(/tmpLimitNum/,f);var d=b("#content-mod-filtered-story-list-MOD-EVERYTHINGLUBBOCK-VIDEO_CENTER_STORY_PAGE");d.empty();d.append("<div class='loader'><img src='https://www.everythinglubbock.com/nxs-main-v2-theme/images/loader.gif' alt='Loading'></div>");b.ajax({type:"GET",url:c}).done(function(h){var i=b(h);d.empty();d.append(i)}).fail(function(){d.append("<p class='text-center'>Oops. Something went wrong. Please wait a minute and refresh your browser.</p>")})})})(jQuery,AUI());/*]]>*/</script> </div> </div> </div> </div> </div> <div id="p_p_id_56_INSTANCE_3307_" class="portlet-boundary portlet-boundary_56_ portlet-static portlet-static-end portlet-borderless portlet-journal-content " > <span id="p_56_INSTANCE_3307"></span> <div class="portlet-body"> <div class="portlet-borderless-container " style=""> <div class="portlet-body"> <div class="journal-content-article" id="article_10155_54787063_MOD-AMINO-UPPER-RIGHT-MR-AD_1.0"> <!-- Begin: Ad --> <section class="module mod-wrapper mod-ad "> <div id="mr1-157368" class="ep-ad-slot mod-body mr1" data-ad-json='{"baseAdUnitPath":"nx.klbk","contentId":"","isCompanion":true,"isOOP":false,"networkID":"5678","disableRefreshOnResize":false,"siteKey":"","size":[[300, 250]],"lazyLoadDisabled":false,"moduleRefreshable":true,"pos":"mr1","wxTargeting":{"skycond":"","temp":"","svwx":false,"sclose":false,"precip":"0"}}'></div> <script type="text/javascript">/*<![CDATA[*/if(EP&&EP.Utils&&EP.Utils.AdUtils){EP.Utils.AdUtils.registerAd("mr1-157368")};/*]]>*/</script> </section> <!-- End: Ad --> </div> </div> </div> </div> </div> <div id="p_p_id_56_INSTANCE_8867_" class="portlet-boundary portlet-boundary_56_ portlet-static portlet-static-end portlet-borderless portlet-journal-content " > <span id="p_56_INSTANCE_8867"></span> <div class="portlet-body"> <div class="portlet-borderless-container " style=""> <div class="portlet-body"> <div class="journal-content-article" id="article_10155_54787063_MOD-EVERYTHINGLUBBOCK-STAY_CONNECTED_1.0"> <section class="module mod-stay-connected-list"> <header class="mod-header"> <h3>Stay Connected</h3></header> <div class="mod-content"><ul class="list"><li><i aria-hidden="true" class="fa fa-facebook"></i> <a href="https://www.facebook.com/KLBKNews">KLBK Facebook</a></li><li><i aria-hidden="true" class="fa fa-twitter"></i> <a href="https://twitter.com/KLBKNews">KLBK Twitter</a></li><li><i aria-hidden="true" class="fa fa-facebook"></i> <a href="https://www.facebook.com/KAMCNews">KAMC on Facebook</a></li><li><i aria-hidden="true" class="fa fa-twitter"></i> <a href="https://twitter.com/KAMCNews">KAMC Twitter</a></li><li><i aria-hidden="true" class="fa fa-apple"></i> <a href="https://itunes.apple.com/us/app/everythinglubbock-klbk-kamc/id641339887?mt=8">Everything Lubbock iPhone App</a></li><li><i aria-hidden="true" class="fa fa-android"></i> <a href="https://play.google.com/store/apps/details?id=com.newssynergy.everythinglubbock">Everything Lubbock Android App</a></li></ul></div></section> </div> </div> </div> </div> </div> </div> </div> </div> <div class="portlet-layout row"> <div class="portlet-column column large-12" id="column-6"> <div class="portlet-dropzone portlet-column-content" id="layout-column_column-6"> <div id="p_p_id_56_INSTANCE_2827_" class="portlet-boundary portlet-boundary_56_ portlet-static portlet-static-end portlet-borderless portlet-journal-content " > <span id="p_56_INSTANCE_2827"></span> <div class="portlet-body"> <div class="portlet-borderless-container " style=""> <div class="portlet-body"> <div class="journal-content-article" id="article_10155_54787063_CONVS-AMINO_AD_SLOT-AMINO_AD_SLOT-54807161_1.0"> <!-- Begin: Ad --> <section class="module mod-wrapper mod-ad "> <div id="leaderboard3-128546" class="ep-ad-slot mod-body leaderboard3" data-ad-json='{"baseAdUnitPath":"nx.klbk","contentId":"","isCompanion":false,"isOOP":false,"networkID":"5678","disableRefreshOnResize":false,"siteKey":"","size":[[728, 90], [320, 50]],"lazyLoadDisabled":true,"moduleRefreshable":false,"pos":"leaderboard3","wxTargeting":{"skycond":"","temp":"","svwx":false,"sclose":false,"precip":"0"}}'></div> <script type="text/javascript">/*<![CDATA[*/if(EP&&EP.Utils&&EP.Utils.AdUtils){EP.Utils.AdUtils.registerAd("leaderboard3-128546")};/*]]>*/</script> </section> <!-- End: Ad --> </div> </div> </div> </div> </div> </div> </div> </div> <div class="portlet-layout row"> <div class="portlet-column column large-4" id="column-7"> <div class="portlet-dropzone empty portlet-column-content" id="layout-column_column-7"></div> </div> <div class="portlet-column column large-4" id="column-8"> <div class="portlet-dropzone empty portlet-column-content" id="layout-column_column-8"></div> </div> <div class="portlet-column column large-4" id="column-9"> <div class="portlet-dropzone empty portlet-column-content" id="layout-column_column-9"></div> </div> </div> <div class="portlet-layout row"> <div class="portlet-column column large-12" id="column-10"> <div class="portlet-dropzone empty portlet-column-content" id="layout-column_column-10"></div> <section class="portlet-layout row"> <div class="portlet-column column medium-6 large-6" id="column-11"> <div class="portlet-dropzone empty portlet-column-content" id="layout-column_column-11"></div> </div> <div class="portlet-column column medium-6 large-6" id="column-12"> <div class="portlet-dropzone empty portlet-column-content" id="layout-column_column-12"></div> </div> </section> </div> </div> </section> </div> <form action="#" id="hrefFm" method="post" name="hrefFm"> <span></span> </form> </div> <!-- begin: FOOTER --> <footer id="footer"> <div class="row"> <div class="column"> <div class="site-logo"><a href="/" title="Go to EVERYTHINGLUBBOCK"><img src="https://static.lakana.com/nxsglobal/global/theme/images/nexstar-logo-white-nmg.png" alt="LAKANA"><div class="site-logo-wrapper" style="background:url(https://static.lakana.com/nxsglobal/global/theme/images/nexstar-logo-white-nmg.png)"></div></a></div> <ul class="social-share"> </ul> <div class="footer-links primary"> <div class="links"> <h4><a href=""></a></h4> <ul> <li><a href=""></a></li> </ul> </div> </div> <div class="footer-links secondary logos"> <ul> </ul> </div> <div class="footer-links secondary"> <ul> <li><a href="/contact-us" >Contact Us</a></li> <li><a href="/about-us/terms-of-use" >Terms of Use</a></li> <li><a href="/privacy-policy" >Privacy Policy</a></li> <li><a href="/privacy-policy#advertising" >About Our Ads</a></li> <li><a href="https://media.everythinglubbock.com/nxsglobal/everythinglubbock/document_dev/2018/03/30/Lubbock%2CTX_EEO_Public_File%202018_1522423574373_38723434_ver1.0.pdf" >KLBK EEO Report</a></li> <li><a href="https://publicfiles.fcc.gov/tv-profile/klbk-tv" >KLBK FCC Public File</a></li> <li><a href="https://publicfiles.fcc.gov/tv-profile/kamc" >KAMC FCC Public File</a></li> <li><a href="https://media.everythinglubbock.com/nxsglobal/global/theme/NexstarCCCertification.pdf" >Nexstar CC Certification</a></li> </ul> </div> <p class="copyright">&copy; 1998 - <span id="copyrightYear">2016</span> EverythingLubbock.com | <a href="www.nexstar.tv" title="Nexstar Broadcasting, Inc">Nexstar Broadcasting, Inc.</a> | All Rights Reserved.</p> </div> </div> </footer> <!-- end: FOOTER --> <!-- Begin: Ad --> <section class="module mod-wrapper mod-ad "> <div id="mweb-adhesion-174681" class="ep-ad-slot mod-body mweb-adhesion" data-ad-json='{"baseAdUnitPath":"nx.klbk","contentId":"","isCompanion":false,"isOOP":false,"networkID":"5678","disableRefreshOnResize":false,"siteKey":"","size":[[320, 50]],"lazyLoadDisabled":false,"moduleRefreshable":false,"pos":"mweb-adhesion","wxTargeting":{"skycond":"","temp":"","svwx":false,"sclose":false,"precip":"0"}}'></div> <script type="text/javascript">/*<![CDATA[*/if(EP&&EP.Utils&&EP.Utils.AdUtils){EP.Utils.AdUtils.registerAd("mweb-adhesion-174681")};/*]]>*/</script> </section> <!-- End: Ad --> <!-- Begin: Ad --> <section class="module mod-wrapper mod-ad "> <div id="dt-adhesion-138940" class="ep-ad-slot mod-body dt-adhesion" data-ad-json='{"baseAdUnitPath":"nx.klbk","contentId":"","isCompanion":false,"isOOP":false,"networkID":"5678","disableRefreshOnResize":false,"siteKey":"","size":[[2, 2]],"lazyLoadDisabled":true,"moduleRefreshable":false,"pos":"dt-adhesion","wxTargeting":{"skycond":"","temp":"","svwx":false,"sclose":false,"precip":"0"}}'></div> <script type="text/javascript">/*<![CDATA[*/if(EP&&EP.Utils&&EP.Utils.AdUtils){EP.Utils.AdUtils.registerAd("dt-adhesion-138940")};/*]]>*/</script> </section> <!-- End: Ad --> </div> <!-- end: WRAPPER --> <!-- omniture scripts --> <script type="text/javascript">/*<![CDATA[*/Liferay.Util.addInputFocus();Liferay.Portlet.runtimePortletIds=["103"];/*]]>*/</script> <script type="text/javascript">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</script> <script src="https://www.everythinglubbock.com/nxs-main-v2-theme/js/main.js?minifierType=js&amp;languageId=en_US&amp;b=6110&amp;t=1535693407000" type="text/javascript"></script> <script type="text/javascript"></script> <!-- custom footer logo link --> <script>/*<![CDATA[*/(function(a){a(document).ready(function(){a("#footer").find(".site-logo > a").attr("href","http://www.nexstar.tv")})})(jQuery);/*]]>*/</script> <!-- Vibrant Media Ad start--> <script type="text/javascript" src="http://idm.us.intellitxt.com/ast/js/idm/idm_itxt.js"></script> <!-- Vibrant Media Ad end--> <!-- gravity beacon code start--> <!-- gravity beacon code end--> <!-- begin: Quantcast --> <!-- end: Quantcast --> <!-- Begin: Footer Customized Content Before Body End --> <!-- start: Google Tag Manager --><noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-5BHL3K" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><script>/*<![CDATA[*/(function(b,m,h,a,g){b[a]=b[a]||[];b[a].push({"gtm.start":new Date().getTime(),event:"gtm.js"});var k=m.getElementsByTagName(h)[0],e=m.createElement(h),c=a!="dataLayer"?"&l="+a:"";e.async=true;e.src="//www.googletagmanager.com/gtm.js?id="+g+c;k.parentNode.insertBefore(e,k)})(window,document,"script","dataLayer","GTM-5BHL3K");/*]]>*/</script><!-- end: Google Tag Manager --> <!-- End: Footer Customized Content Before Body End --> <!-- begin: Footer Customized Content --> <!-- end: Footer Customized Content --> <!-- begin: Taboola Closing Snippet --> <script type="text/javascript">/*<![CDATA[*/window._taboola=window._taboola||[];_taboola.push({flush:true});/*]]>*/</script> <!-- end: Taboola Closing Snippet --> </body> </html> 